Error during install of 10.1

snowgurl

Registered
The installer opens and I can get through about 2/3's of the install -- it looks like up to the part when it is "checking replaced items" or something. Then the screen goes to blue and I get this error:

"The installer has unexpectedly quit (error 0). Press return to restart."

It's in that white text. Pressing return won't restart and I have to use the reset button and, of course, 10.1 is not installed when I restart. I've tried it about 5 times and it just dies in the same spot.

I had picked up 2 of the 10.1 CDs so I tried the other one and got the same error. I have 10.0.4 and haven't had any problems with it. It seems like a memory error but I have plenty of memory. I don't know what else to look at. Any help would be appreciated (my info is below). Thanks!
 

jimr

McInstigator
though I didn't find logging to be that useful.

seems it chokes on some file permissions or access privelige.

fortunately I had a spare partition to install onto.

now I have 10.04 and 10.1 installed.

though I doubt I will ever boot back to 10.04, it is usefule to line the directories up and compare things.

--------------------------
I doubt I will ever reboot.
if you don't have the diskspace....
probably you should start looking around for what you want to keep.

store it off somewhere....

don't forget to keep the contents of your

/etc folder

/Users

/Library/StartupItems/[ if you did anything custom there] (or same name in /System)


you will have to sudo or use root access to copy the files listed and then chown them all to your own user name.


do not replace the files in the new /etc with the old.

you may copy all or most of the
/Users/[your name]/Library/Preferences

this will preserve most of your environment.

you will have to manually rebuild your dock, if you have customized much.

You will learn a bunch.....
 

snowgurl

Registered
Thanks for your reply. Unfortunately, I went ahead and tried a few things on my own and really screwed it up. I reinstalled the 10.0.4 update thinking I was may be missing something I needed. I updated the firmware -- I thought I had the most recent update but I didn't. Then I tried 10.1 again and it worked fine -- until I restarted. It won't restart! I get the happy mac for about 20 seconds and it all sounds normal then it goes to a white screen and stops. I can still start from the CD -- it's stuck in there now. It doesn't help me much cuz it only opens in the install mode and I can't get at the hard drive. And, I can't get another CD in to start from.

So, on one of my many tries to restart I got this bad kernel screen. It said a whole bunch of stuff but I noticed:

Darwin Kernel 1.4
CPU code error 1 corrupt stack
root:xnu/xnu-201.obj~1/ReleasePPC

Did something not install in the right place or not at all?

I want to try your suggestions but I need to restart from another disk. How do I get that 10.1 CD out of there? I can't find a little pinhole? I've never messed my machine up this much!
 

KrinkleCut

crispy subgenius
Snowgurl, try booting from the OS X cd and when the installer starts (the first scrren you click through where it asks for your language default) go into one of the pulldown menus and you will see the Disk Utility. Try running this.
 

jimr

McInstigator
it is just a matter of timing.

hold on the CD eject button as you are restarting. (keep your hand low and out of the way)

or shut down.

anyway, while it's in there try to repair that disk.

the kernel is the right version.

but damaged files, or file directory structure will cause these kind of errors.
 

cybergoober

Neomaxizoomdweebie
...or you can hold down the mouse button on startup. ;)
 

snowgurl

Registered
The "hold down the mouse" thing worked. Thanks. I ended up doing a clean install and started from the beginning. It took me a couple days but it's all done now -- finally. It really does run fast! I like it! Now I've got to get php and mysql back up and running. It looks like php is installed but not running -- so I'm gonna look around for some help with that now.l
 
Top