Espon printer/scanner support in OS 10.1

tcooper

Registered
Now that people are actually getting their hands on the final 10.1 release I wonder if anybody tried using any of the following with 10.1 (Native or Classic mode)?

Epson Stylus Color 800
Epson Perfection 1650 USB
Expression 1680 Professional Firewire

The Epson web site says that the following printers are supported in OS 10.1...

Epson Stylus COLOR 740, Stylus COLOR 740i and 740SE
Epson Stylus COLOR 760
Epson Stylus COLOR 777, Stylus COLOR 777i
Epson Stylus COLOR 860
Epson Stylus COLOR 880, Stylus COLOR 880i and Stylus COLOR 8 cubed.

and that the following scanners are supported in Classic mode via USB...

Perfection 610 - TWAIN L 1.00E
Perfection 636U - TWAIN 3.20A
Perfection 640U - TWAIN L 2.01A
Perfection 1200U - TWAIN 4.01A
Perfection 1240U, 1640SU - TWAIN 5.02A
Expression 1600, 1640XL, 1680 - TWAIN Pro/Pro Network 2.00A*
Stylus Scan 2000, 2500 - TWAIN (v.1.10A); Printer (v6.25E)**
Photo PC 80O, 850Z, 3000Z - EPSON Photo! 3 (v.1.40E)***
Photo PC 3100Z - USB Storage Device

The printer models are all the newer ones while the scanners are all the older models.

I'm wondering if my hardware might work even if it's not "officially" supported yet.

Thanks,
 

walrusjb

Registered
I can confirm the 880 even from 10.0.4 - but printing is BEYOND CRAP at this point. No control over paper weight/type, etc. - all of the basics that make a printer a printer these days.

Ended up hooking it up to my wife's OS9 machine so I could get more options - pain on top of it to transfer everything over the network just to print.

I had read complaints about Epson's OS X angle for months and thought nothing of it (my 1520 is hooked up to a NT box - most of my printing is through there) - UNTIL I actually tried it.

And mine's ONE OF THE SUPPORTED ONES!?!

{/end plausible rant mode}
 

omegaroot

Apprentice Codemonkey
I have an Epson Color Stylus 980, which they are supposed to be working on support for soon! anyhooo... funny little anecdote,

When I first booted into 10.1 GM I went directly to the print center. I got all excited cause the exact printer model came up and then I noticed the little label to the right "Unsupported Printer."
 

oldmac

Registered
I don't know if you've seen the list of printers Epson "hopes" to support under 10.1, but here it is: http://support.epson.com/webadvice/wa0301.html.

Now that 10.1 is officially released, perhaps we need to remind Epson that we too "hope" (Epson's word) that they will get on the ball and get some drivers out. There is a VP of Marketing whom I sent an e-mail to about six weeks ago, and tech support actually responded, sending me a copy of that list! He is Dan_Crane@ea.epson.com and we should all e-mail him. HP & Lexmark have released drivers for their printers from the last couple of years. I have a Photo 870, which does a great job, but I can't even print an AppleWorks 6.2 document.
 

groverhoo

Registered
Later on that same support page, however, Epson writes:

"We hope to offer OS X version 10.1 drivers for the EPSON Stylus Color 740, 760, 860, 777, 880, 900, 900N, 980 and 980N, as well as the EPSON Stylus Photo 870, 875DC, 1270, 2000P, 780, 785EPX, 890 and 1280, including future products. This fall we also plan to provide drivers for the Perfection 1250, 1650, Expression 1680 and 1640XL scanners."

Of course, my printer is the Color 900 - and yes, it is marked as an "Unsupported Printer". At least it actually recognizes what is connected.

Just remember that they actually listed MORE devices than what tcooper listed... I think we should give them a call.

Grover
 

tcooper

Registered
I guess my point isn't so much what has Epson said they/Apple currently support or plan to support.

It really is more of a has anybody tried to use the wrong driver with an unsupported printer and what did they find. I don't even know if this is possible anymore...

I used to use a generic LaserWriter 8 driver when I didn't have a postscript driver for a specific printer and this usually worked. I know that most Epson printers don't suppor postscript because if they did then all we'd have to do is "talk" Postscript to them over their interface(s). Many models of HP printers (in Windoze/DOS) can use subsequent printer drivers. I know this as I still have to maintain some pretty nasty DOS code where I work. I guess that is the spirit of DOS backwards compatability.

It's a shame it can't be so easy with printers/scanners/OS that are simply superior. I guess you can't have it all! :D
 

Cubester

Registered
In old version of OS X (e.g. 10.0.2) I could print flawless to my Epson 740. Since then, and even with 10.1, I have turn on/off the printer, unplug/plug the USB port, remove/add the printer etc. and none of these steps produce a consistent result. Here is the strangest part. If I run OS 9.2.1 in Classic mode I can print anything within that OS.

Does anyone has have a similar problem? Have you been able to overcome it? if so, how?

THANKS!
 

plakey

Registered
My Expression 1600 (FireWire) has started in work under 10.1.1 using VueScan 7.3... this is good news. Also, I grabbed a driver off of the UK Epson FTP server for my 2000P, which works like a charm now.
 

tcooper

Registered
Since my original post I have read others and discovered two things.

1. Even though the Epson site says my scanner is NOT supported in Classic mode (I've been rebooting into OS 9.2) it actually DOES work fine, at least in "scan to file" mode. I found this out quite by "accident" when my daughter pushed the scan button in OS X.
:)
This may be because when I installed 10.1 I wiped the drive and didn't install 9.2 first but installed 9.2 (and the Epson software) after I had finished the 10.1 installation.

2. I downloaded and tried the VueScan software and can't help but think Epson should be concerned that a third party software company can come up with software that works with their hardware before they can!

VueScan works great and I'll be buying it soon if Epson doesn't come up with Twain drivers so that I can scan directly into Photoshop. Which begs the question... Has anybody found Twain drivers from somebody else that work?

Cheers...
 

karavite

Registered
My 740i worked great on 10.1, but big problems in 10.1.1 until I plugged it in directly instead of through a UCB hub.
 

kcmac

Registered
My 888 works great now. When I first installed it, I got a funny buzz in my phone line and I could not use it if I was connected to the internet through my 56K modem on my iBook. (Using OSX 10.1.1.

Found out that I needed to go to the print center, delete my printer and reselect it making sure it was connected to my USB port. (Must have been hooked to the modem for some strange reason.)
 
Top