everything crashes all the time

eJacqui

Registered
Hi. I am having a problem on my iBook where every single application that comes with Mac OS X Publc Beta (TextEdit, any of the Grab Bag items, Calculator, Music Player, etc.) "unexpectedly quits" 100% of the time. I cannot open one single thing without it unexpectedly quitting within 30 seconds of my opening it. I can't even try to use anything on it because nothing stays open for me long enough, and not on the 2nd, and 3rd, and 4th try either.

I wasn't sure if anyone else went through this or not. I tried to read through the past posts but didn't come across anything like this.

-<>-
Jacqui

---------------------
iBook - 3.2 GB, 96 MB ram, 300 MHz, 24x CD
 

eJacqui

Registered
Yep, it's about the ONLY thing that'll stay open for longer than 30 seconds... why?

-<>-
Jacqui
 

eJacqui

Registered
Oops, let me correct that last post (my boyfriend just reminded me of what happened). It crashed at the terminal too. I tried to type one command and it went boom. :(

-<>-
Jacqui
 

Pascal

Official visitor
Hi !

Since your problem seems isolated (you seem to be the only one to have it) I would tend to beleive is on your computer, rather than with OS X.

Let us go through a few questions :

1- Have you checked your disk's integrity with Tech Tool Pro or Norton Disk Doctor ?

2- Have you defragmented your HD prior to install ?

3- Is there enough free space on the disk for the swap file (virtual memory) ?

4- Have you installed new hardware ? Maybe some of it is not supported by the PB. If it is new RAM, maybe some of it is spoiled (check it with Tech Tool Pro).

These may seem very basic questions, but it is a start since your problem does not seem widespread...

If you went through this list and the problem is not there, then maybe you could do a complete backup of your system and reinitialize the whole disk using Apple drivers. If you can, making two partitions (with OS X's at least 1,5 GB). This should solve the problem that I would surmise is in the disk's logical structure (corrupted HFS+) or in a corrupted OS 9.
 

eJacqui

Registered
1) Yes, I've checked the disk with both Norton and Tech Tool Pro
2) Not only have I defragmented recently, but I just formatted the whole damn thing prior to install. It was 100% blank and initialized in HFS extended format.
3) There's PLENTY of free space, way more than necessary
4) I did install new ram a LONG time ago, but I did check it with TechTool and it said everything was okay.

There is no OS 9 on it because I reformatted the disk before installing.

<shrug>

-<>-
Jacqui
 

Pascal

Official visitor
Wow, you quickly posted a reply... this is almost a telephone conversation.

Not to be outdone, I'll reply to your post as fast as you did to mine... ;-)

Seriously, since these basic things are out of the way...

a) are you using an Apple driver for the hard drive ?

b) are your firmware up-to-date ? see :
'http://asu.info.apple.com/swupdates.nsf/artnum/n11702'

(I'll be back in a few minutes to see your answer ;-) )
 

Pascal

Official visitor
Well, I would recommend hugging you iBook, taking the time to tell him how nice he is.

THEN I would tell the naughty OS X cd to be nice with the iBook and try to be good friends now.

Maybe it would help ????????????

I'll sleep on this and see if I come up with a solution in the morning...
 

eJacqui

Registered
Actually, you'd be surprised, but we did try that already. :)

By this time, I just gave up and reinstalled the original 8.6 back onto the machine, but I'm still trying to find answers in hopes of being able to use it (the beta) again one day... :p

If you come up with anything, let me know, please. :)

-<>-
Jacqui
 

Gregory

Registered
Firmware? PRAM? Etc?

STAY AWAY FROM NORTON!

Run Disk First Aid that comes with X - has same version as 9.0.4 but Sept 2000 date.

Also, you should use Drive Setup from 9.0.4 or one that comes with X.

You were running 8.6 so DFA and Drive Setup are not current enough. And even Norton 5.03 isn't up to the HFS+ used by X.

Seeing this is an OS X only install, no Classic (needs 9.0.4), I'd just try again and maybe carefully watch. Maybe try UFS instead of HFS+. Don't just Erase - the disk Driver has to be Updated.

I really think that could get your iBook up and running.

Gregory
 

eJacqui

Registered
Hi Gregory,

I *used* to have OS 9 installed before I reformatted while installing the OS X beta. I only went back to 8.6 because that was from the original iBook CD and I haven't gotten around to upgrading up to OS 9 again yet...

I updated the firmware before the beta, and I also did all sorts of other fun things, like zap the pram, etc.

And when I formatted the disk, I did not just erase. I used the "format" option that is in the OS X Beta installer.

Did I mention that I had to reinstall it probably 3 times before it would work, too? Hmm..

I might try again to install the beta soon, but tell me if you have any thoughts on this.

-<>-
Jacqui
 

Gregory

Registered
>>>
I *used* to have OS 9 installed before I reformatted while installing the OS X beta. I only went back to 8.6 because that was from the original iBook CD and I haven't gotten around to upgrading up to OS 9 again yet...

I updated the firmware before the beta,
<<<<

Ouch! (and Sorry;(

Did you NEED to update the firmware? other stuff? Adage, too many cooks spoil the soup, comes to mind.


I don't know how to get it back to "ground zero" but might. Also, seeing it was not a walk in the park to install to begin with there is likely something more to this than a simple "boot from OS X CD" and perform install. I didn't think you had erased only. But only pointing out that initializing with Drive Setup "Updates" the driver used.


"Practice makes perfect" but what's the lesson here? Sounds like you've done it right and learned something. :(


Gregory
 

eJacqui

Registered
If 96 wasn't enough, I think the ENTIRE operating system would be at a complete turtle pace, don't you think?

But it was the exact opposite... things were running speedy as ever, except that everything decided to unexpectedly quit.

<shrug>

I'm going to try reinstalling it very soon.

-<>-
Jacqui
 

Gregory

Registered
Taking a look at CPU Monitor, Process Viewer, Top, and it shows that X has every process swapped partially to disk (virtual), some resident, even if it is not being used currently.

Classic alone using 80MB RAM and 108MB Virtual = 188 MB total.

Mail = 20MB or more (12MB resident, 6 - 80 MB Virtual)

Total Virtual: 800 MB

It is possible for unix systems to end up with even more swapped out (couple GB).

CPU and Memory usage shows % and then look at statistics.

This is one hungry OS! But not unusual for servers or Unix.
 

aarontrip

Registered
All I can think of is maybe it's a device you are using...like a zip drive, scanner, printer ect. ect. You might want to try unplugging everything from your USB ports and give it a whirl. We all (well some of us) know plugging things like zip drives and such into the USB keyboard ports causes problems, so maybe your having a problem similar to that. Either that or I'm a big dummy. By the way I'm on my Bondi iMac rev. A 233MHz with only 96MB's too and my OSX Beta works nice (using it right now), so I doubt it's your RAM. So good luck.
 

eJacqui

Registered
Unfortunately, the blame cannot be placed on any peripheral devices because, quite frankly, on my poor little iBook, I use none.

In fact, I'm slightly afraid of trying to install it on my main machine (blue & white G3/256MB/32GB/DVD) solely *because* of all of my devices... that's why I wanted to try it on my little iBook first, because he is so young and pure and uncorrupted... :p

Oh well. Keep letting me know what you guys think. :)

-<>-
Jacqui
 

jtrott

Registered
Did you try updating your disk driver with the latest version of Drive Setup?
The other thing that might be worth trying is to format your disc using the MacOS 9 drive setup before installing MacOS X and then not selecting a format of the disc using the MacOS X Beta installer. The other gotcha is that the 8.6 installer will downgrade your disk driver as part of it's install process.....
JT
 

Pascal

Official visitor
I'm really wondering : have you checked your hardware using TechTool Pro ? Maybe there is something in there.

Considering that you seem to have a vanilla iBook (maybe a vanilla-and-blueberry or a vanilla-and-orange or a vanilla-and-... (huh, grey ?), but still a plain iBook, you get my "drift"), the problem has to be from within.

As I understand :
a) you have completely reformatted the drive (not simply erased and updated the driver)
b) you have not installed new RAM recently
c) nothing is plugged in your iBook : your Mac is an island
d) you have the only iBook in town which crashes with Mac OS X
Conclusion ?
(drum rolls)
Your iBook has a problem !!!
(ta-da !) ;)

If I were you, I would install TTP and get it going on its intensive tests suite for the night (repetitively testing all the hardware, but skipping the disk integrity part, because you'll reformat everything anyway). In the morning, you'll see if your iBook has a problem somewhere...

On a last note, since there are more and more success reports using this method when everything else has failed : reformat your drive in two partitions : the first one containing OS 9 and the second one (1.5 GB in size) containing OS X. That might also help...

Keep us posted !
 
Top