Experimental MySQL.pkg double-click installer

matvon

Registered
I have a MySQL package file that should allow you, provided you know how to configure and use MySQL, to install it on your system.

Email me if interested.. I need testers before releasing it to the public.

Matt
 

Thies

Registered
I am really looking for mysql on MacOSX.
Would be great, if you could send it to thies@schule-im-netz.de
Thanks.
 

Thies

Registered
Hi Matt,

I did everything like you told me and it works great on MacOS X PB on Powerbook G3 Lombard.

Thanks a lot!
Thies
 

Anxietyboy

Registered
Matt is amazing!!!!!! I have MySQL and PHP 4.0 working on a beige 233 and it is absoluteley amazing I don't think I will ever touch my Linux machine again!
 

dani++

usin UNIX since '92
(followup: it seems that Matt has done just that, if you explore his site you'll find detailed instructions on building the apps...)


Matt,


great stuff!


I am currently trying to compile apache with php, php4 and mysql in MacOS X. It seems that you have done it all already!

Thanks for providing the files. But I would really appreciate it if you posted your favourite configure switches...

Moreover, there are some articles on
http://www.stepwise.com
regarding the installation of apache on a directory other that the system ones (on /usr/local) on MacOS X Server, we could take a look at those to apply that info on MacOS X...


thanx,
dani++


[Edited by dani++ on 10-23-2000 at 08:24 PM]
 

dani++

usin UNIX since '92
In trying to compile several packages (mySQL, php, apache,...) i keep getting this make error:

cp: pear is a directory (not copied).
make[2]: *** [install-programs] Error 1
make[1]: *** [install-recursive] Error 1
make: *** [install-recursive] Error 1

which strikes me as very strange, as if 'cp' were trying to copy entire directories
(without providing any switches like -r) and of course failing...!

moreover, when I configure mySQL, the script fails when it tries to guess which 'ls' options does it need to detect the mysql server running and cat its pid to a file.

I am using Matt's compiled binaries for now but if someone has encountered similar problems please post. Even Matt's compile instructions fail in the same manner. maybe we could modify the configure script with a custom 'ls' configuration that detects mysqld, this might be related to Matt's compiled binary of mysqld that cannot die.

dani++
 

dani++

usin UNIX since '92
Nope...

I have been trying to get it all together lately.

(1) I am able to compile apache 1.3.14 using instructions at http://www.stepwise.com . Moreover, those configure options do not step upon the system configuration of apache (you can get back to the official apache).

(2) I downloaded php again and using Matt's instructions (using the new apache source tree) tried yet again to recompile the php module into apache. I keep hitting the cp pear error...

I have been able to install it using '--disable-pear', but disabling such an option that comes as standard... not wise.

(3) Moreover, I've tried to compile mod_perl using the .14 source tree. I've been able to cheat its makefile.pl to make it to compile but haven't yet tested it. I'll post the changes here if I achieve success with this. Are the ap_conf.h on the System/Library/Frameworks/ useful to compile modules without the actual source tree?
[Edit: I've just tried that last idea with no success]

(4) BTW, how do I know what's really compiled into apache, for all that I know, mod_perl could already be on apple's or Matt's apache versions.
[Edit: There isn't, test.php tells me that, as well as apache -l]


Would somebody that has compiled php or mod_perl pshed some light into this subject?


Tanks to Matt, now at least I have MySQL+php+apache. :cool:

I would like to add mod_perl to the mix... :confused:



dani++


[so far, I've achieved more stuff than on my other Linux/MacOS X Server boxes :confused: ]

[Edited by dani++ on 11-17-2000 at 05:49 PM]
 

Angus_D

Registered
Ho hum...
I got apache to compile with mod_perl fine this morning. Not sure exactly how I did it, but it worked fine. I don't remember doing anything out of the ordinary.

PHP 4.0.3 has a problem that prevents it from building on OS X. However, I can tell you that 4.0.5-dev works fine, and even compiles as a dynamic library so you don't need to recompile Apache.
 

fchang

Registered
I was able to compile PHP 4.0.4 rc6 from http://qa.php.net last night as a DSO, so that apache can load it without me having to re-compile apache myself. The only remaining issue, it would seem, is the pear/ directory naming issue, which can be circumvented by following the instructions at this page http://devious.jpl.nasa.gov/php.

As I am also just learning PHP, I stumbled across its support for parsing XML files using either the DOM or the expat approach. However, to use the DOM approach, libxml needs to be built. I gave that a try last night, but its config files are a bit old and don't properly recognize OS X Beta yet....
 

Thies

Registered
I have summarized instructions for the Perl DBD::mysql package on my web site: http://invictus.usask.ca/macosx.
Giving back to the community [/B]
When typing cpan> make DBD::mysql I get the following error:

dyld: perl multiple definitions of symbol _strtol
/System/Library/Frameworks/System.framework/
Versions/B/System(strtol.o) definition of _strtol
/Library/Perl/darwin/auto/DBD/mysql/mysql.bundle definition of _strtol


In not a UNIX-crack and this error message doesn't mean anything to me. What's wrong?

Thanks for help!
Thies
 

bobDalgleish

Registered
Originally posted by Thies
When typing cpan> make DBD::mysql I get the following error:

You skipped this step:
Instructions for Perl DBD::mysql Installation

1. Fix mySQL installation


su
cd /usr/local/lib/mysql
ar d libmysqlclient.a strto.o
ranlib libmysqlclient.a

This step removes the redundant definition of _strtol
 

dani++

usin UNIX since '92
So far the instructions posted here work well...


I\'ve installed PHP (doing the PEAR renaming trick) and it works seamlessly.

I\'ve installed CPAN and aside from a few quirks, it works reasonably well.

Mysql compiles and installs out of the box, though I don\'t know if that issue of the immortal mysqld is solved yet. It seems that some people configure mysqld to run not as root but as a special user \'mysql\', that might be related.

I\'ve finally compiled mod_perl as a module and it seems to work well, though I haven\'t been able to run make test at all (it stubbornly tries to run \'httpd\'). Do you know of other means of verifying the installation?

I\'ve been trying to install the Everything community system (http://www.everything2.com http://www.everydevel.com) and after installing mod_perl and all the required perl modules, its installer tells me that:
dyld perl: undefined symbols
_compress
_uncompress


it seems that perl is unable to find zlib... though i have both Apple\'s and a custom installed one on my system (required to install OpenSSH as in http://www.stepwise.com)
Does anybody know how to tell dyld or perl that I do have both symbols somewhere?

Thanks in advance,

Dani++

 

dani++

usin UNIX since '92
Could Bob or anyone else post the instructions for installing the Perl::DBD package?
<p>
I am trying to install it and I am no longer able to access Bob's instructions.
<p>
CPAN chokes on the _compress and _uncompress symbols (and it didn't if I followed Bob's instructions) on make test.
<p>
I was able to install Zlib by manually editing its config.in file and changing the paths there. Though perl is still unable to find both _compress and _uncompress symbols!!!

TIA

dani++
 

bobDalgleish

Registered
Originally posted by dani++
Could Bob or anyone else post the instructions for installing the Perl::DBD package?
<p>
I am trying to install it and I am no longer able to access Bob's instructions.
<p>
CPAN chokes on the _compress and _uncompress symbols (and it didn't if I followed Bob's instructions) on make test.
The instructions are in a new and better place:

http://duke.usask.ca/~dalglb/macosx/

Also, CPAN does NOT require the compression libs, although it would like them. In place, it uses gunzip to uncompress programs.
 

dani++

usin UNIX since '92
Thanks bob...

DBD::mysql

I am trying to use your instructions but it seems that the system is screwed as on the mysql directory 'perl Makefile.PL' itself complains about the missing symbols _compress and _uncompress. So I cannot create the Makefile necessary to run a 'make realclean' so I can start from scratch.
<br>
<br>
setting the environment variable DYLD_PRINT_LIBRARIES sets the dyld to print on stderr the names and paths of the libraries it is using. funny thing is that by installing without using your instructions i created /Library/Perl/darwin/auto/DBD/mysql/mysql.bundle
that does not have the required symbols... and perl stubbornly tries to use that library on invocation of 'perl Makefile.PL'. Interesting deadlock.
<br><br>
[update.. I have temporarily moved the offending mysql.bundle file and been able to invoke perl Makefile and finally setup everything okay!!!]

 

Mikan

Registered
Is there any chance of instructions/a package with support for MS SQL compiled into the php/apache install rather then mySQL. I'm forced to stay on MS SQL for now and have little experience in compiling apps. Here's to hoping.
 
Top