Exposé and Dashboard keys keep resetting.

Convert

Tech
Hey,

The problem is that whenever I press F9-F12 they do nothing. I check the Exposé and Dashboard Preference panel and it shows a dash for each key assignment.

How do fix this? I have repaired permissions, Tiger is up to date, running on a Powerbook 1.33 Ghz 12 inch if that matters.
 

cfleck

tired
It sounds like you may have disabled dashboard somehow.
Fire up the terminal and run these commands...

defaults write com.apple.dashboard mcx-disabled -boolean NO
killall Dock

Give it a couple of seconds and try those 'f' keys again. If that doesn't work, I've got nothing.
 

adambyte

Registered
Hmm... I willing to bet it's something a little simpler... go to the Keyboard and Mouse preference pane, and then click the "Keyboard" tab. Make sure "Use the F1-F12 keys to controls software features" is unchecked. Maybe that will help?
 

Convert

Tech
Tried both, no luck.

I think it's a problem with a game I play (World of Warcraft). It seems to happen after I play that... hmm.

Thanks anyway, anyone else who plays WoW have this problem?
 

jchebul

Registered
I'm playing it and having the same problems. I hadn't made a connection between the two until now. I'm not sure what would be causing it, as it only started for me laast week (after three months of playing the game).
 

Incubated Funk

Registered
Does the game use these specific keys for something? If so that is what will be knocking them out. I had a similar problem when i assigned a shortcut in Logic Pro to something OsX was already using. Obviously i just switched it back and it went away, not sure if that is an option for you.

If it is, see if you can reassign the keys in the game prefs
 
Top