External Hard Drive will not mount but does show up in Disc Utility

Discussion in 'Hardware & Peripherals' started by RegularX, Sep 12, 2007.

  1. RegularX

    uix_expand uix_collapse

    Sep 12, 2007
    Likes Received:
    I have an external hard drive (Maxor 3200) with both a Windows and OS X partition. About 5 days ago the windows partition was messed up when I had to kill power to the computer when it locked up without ejecting the disc properly.

    A day ago I had my external HD connected to my macbook while I tried to see if there was anything I could do to fix the Windwos partition in OS X (since windows didn't want to cooperate) when it locked up and i had no choice but to restart it by holding the power button down. it didn't eject the HD and guess what? Now that partition it will not mount either.

    It does show up in Disk Utility, However, if I have it connected before I open Disc Utility the program will just say "Gathering Disk Information" forever and never display anything. but it is "grayed out" and when you click mount i get an error that suggest I run repair. running repair however just runs and runs and doesn't do anything however.

    I then tried to use DiskWarrior, but got the error message that the directory structure could not be rebuilt due to hardware failure.

    Moving on I also tried Date Rescue 2, but all that happens is (while the external HD is connected) it just keeps saying "scan for hardware" but the completion bar never moves no matter how long i let it run.

    similarly, FileScavenge will find the device, but won't scan it.

    What are my other options at this point? The fact that is shows up in disk utility at least means the data is still on the disk, so I don't understand why so many programs fail to even recover any data or even find the disk in the first place.

    I have used linux before to recover files from my PC HD when it crashes through the terminal and some command line prompts that forced the HD to mount. i would imagine i could do something similar through the terminal with OS X.

    Any help would be greatly appreciated as I really would like, at the very least, to salvage the information on the disk.

    UPDATE: So I booted up my PC into linux and plug in the HD. The entire mac partition was emedetly reconized. So now I have to wonder why the hell my Mac can't even open the drive? Under Unbuntu it just pops right up (the windows partition however appears to be a goner at this point).

Share This Page