Failing External Drive


Staff member
I'm about ready to pull out my hair. I have a failing/failed external hard-drive. This was a backup drive, but since it was so large, over two years I put other stuff on it, which wasn't a backup of another disk, nor was this disk backed up elsewhere. Silly ME. :(

The main issue is that the drive, while I can get it to mount through a multiple step process and list the files on there and even copy some of the files from it, it eventually just locks up my Mac until I unplug it. This brings back my system to an alive state, then I repeat the multi-step process to mount the drive again, it comes back, and I'm not getting anywhere with this.

The drive sounds fine, no silly/scary sounds. It's a Seagate GoFlex 2TB drive. I ended up taking it out of the external case it came in, and the sucker was the hottest hard drive I've ever held. I stuck it in the freezer to cool off.

It has ATA connections on it, I have a hard drive connection kit, that I can plug power into it and it spins up fine, and I can plug in the ATA to USB cable, but it never wants to mount or be seen using this connection. I can take the "adapter" from the external case and plug it into the drive and with Firewire 800, it mounts right up, then repeat what I described earlier. With USB connection through the original adapter, it has about a 60% success rate of mounting up, but of course, same thing as above.

What else have I done?

I have DiskWarrior and gave it a try. Right out the gate when I used it, it started and said there was not enough memory, so I went to resolve that issue by starting the app from another drive, but can't get DiskWarrior to even open up if that drive is mounted up or connected.

I tried using Disk Aggregator to control whether it mounts up automatically and Read-Only settings and so-forth and so-on. Still can't get any forward progress, because of this short lifespan of the drive after being mounted.

A week ago, before I started to give into this, I knew the drive kept going offline, but hadn't fully grasped the true seriousness of what was happening. I started a repair disk using Disk Utility and fully expected it to last a long time, well, it just locked up my system, just as all the steps above do as well.

I realize there are probably bad blocks and perhaps more than I want to admit on the drive. But it's a good 3-5 minute process once it locks up before you have it mounted again. If I go in and copy a file that hangs up the drive, it becomes a very long and tedious process.

I have Rescue and tried out DiskDrill, which both of those apps, I don't really think my drive is at that state, but it really doesn't matter, because again, after just a minute or two, it locks up my Mac. I've tried different cables, different adapters types and various cords.

I've tried copying the files from the command line (terminal) so that if it doesn't copy, I can just CTRL-C out of the command... but even that is locked up, until I unplug the drive.

I've read there are various issues with GoFlex and later versions of OS X, perhaps there is, but I'm just not sure what to do at this point. It's hampering forward progress in my life because like every issue I can't solve quickly, I keep kicking and kicking it until I solve it.

But, I've learned over the years, the moment I give up and post the question on a forum, minutes, maybe hours later, I will solve the issue, long before anyone replies and typically I don't even get replies.

So, this is just may way of either getting some other brainstorming going on or giving myself a "I solved it" solution by posting this. :)
This is so annoying.

I posted the above post. Decided I should try hooking the drive up to another Mac running 10.9. It connected and I started copying files from it and it seems to be doing it without any hesitation and so far so good. I spent most of the day working at this drive only to post and solve my issue, literally minutes later.

I think it's the process of writing everything out that helps me get a bigger picture and realize what I haven't tried.

So.. now the mystery becomes, why does it not work on 10.10, but works fine on 10.9. Or for maybe its not even 10.9/10.10 related but because of something else installed.
I posted too fast, it stopped working on the 10.9 computer. Hmm... an hour or so went by and I hadn't did anything that that external drive and it was able to copy more data over before it overheated? Granted I don't have it inside that external case, but just the drive itself. But the board on it does get hot, more so than what I think it should. So, maybe it's all related to heat? Maybe I should stick it in the freezer and run it from there? lol
I was going to suggest plugging it into a machine with a different version of the OS on it. Now, since you have noticed that the drive gets unbearably hot, get a portable fan and have it blow cool air on it. That should be easy to do since you do not have it in its enclosure. That is if you have a small fan for the job.

My thinking is a fan would possibly keep it cool enough to allow you to get everything off of it before total failure.

And you now have the task of getting a replacement back up drive or two.
Actually, I have tested the fan method since my last post and it didn't work. Perhaps the files I copied the first round, which was different than when I tested it with the fan, was because those files were not on bad blocks. I don't know. I've finally given up for now. :) I'll try it tomorrow after the drive has plenty of rest. :)

I wonder if it's not the "connector" from the external drive. My only other connector isn't working with that drive, so may have to either buy an adapter to hook it into other cases I have and see if that works. I have HOPE that the drive mechanism is fine and it's just something external, like the build on board or other. If it's recoverable at some point in the future, I'm good with that.

No, haven't picked up any new drives. I have other drives around, but none that are 2TB. I was hoping to not have a whole array of external drives hooked up, but I may end up doing that. :)
I've tried extra cooling on unreliable discs, but it hasn't worked. I have split my stuff on a bigger disc into a lot of sub folders while I could - while the disc worked. Then copied them off one at a time. If you make the subfolders small enough, you can be luck and get a whole one off before the drive stops working. Then repeat each day taking another folder or two off, until it's all off. But multiple externals drives are what you end up with :(

I've been having intermittent problems with external drives. I have two G-Tech drives from the Apple store. The 2TB one has been OK. The 4TB, partitioned into two 2TB parts has been flaky. Last year it wouldn't mount. It would mount immediately if I switched it off and on. I checked the drive and it said it was OK. But the problem continued intermittently. I suspected a firewire cable (bought from Apple Store) and changed sockets and the order of the two drives on the firewire chain. Still intermittent no mount. I changed the cable and it seemed OK.

Then is started doing it again. I got it connected and Disk Utility came up with an error when checked with Verify Disc. Both partitioned failed with errors. Repair on both failed. Disc Utility suggested reformatting the drive.

I went on two weeks holiday. I came back and with a bit more time to spare I set out to reformat the disc drive. Before I did that I tried a quick "verify", which failed. But also a repair, that I tried more in hope than anything else, repaired the partition. so I tried the second partition and that worked too. So I copied the partitions to an old drive, but they are currently working and mounting each time I switch the iMac on.

Still on Mountain Lion on the main desktop due to some legacy software that my wife uses...

I got a LaCie drive and will keep the other one connected while it works but I can't trust it anymore.
Today I plugged it into the 10.9 Mac and got an extra Ext HD I had ready so I could start copying right away from it. I even timed it. I grabbed a folder and dragged it over, was just under 4GB in size, when it finished copying,a bout 5 minutes later, the drive become unresponsive. I tried using my previous methods to remount it, seeing if I could go another 5 minutes. Nope, wouldn't even mount up.

So, the circuit board is toast unless it's something on the inside causing issues, but I doubt it. I will try this again a little later today to see if I get a consistent 5 minutes of time out of it. I found a place, which ironically as the board I need for it, has the first item on their main page. For $49, you ship them your board so they can copy the firmware off of it and onto the replacement board so you have an exact match. Almost worth doing, because at 1.8TB of data on that drive, it will take forever to put it into smaller directories and copy they data over.

I'm also going to try a cooling gel pack on it. With only 5 minutes of time to test, it won't be enough time to create any amount of condensation if wrapped up, but if it extended the drive availability it could be worth a try. LOL. I do have a ice-less electric cooler, not sure if it would be cold enough for the drive, but that might be worth a try as well.
Well, it just gets more exciting. Got my replacement wireless card in today, swapped it out, MacBook Pro booted fine, I could see wireless networks.

Then it just started timing out. So I rebooted and it wouldn't boot up, and not in rescue mode either. Not a problem, I run Time Machine, except my backup drive is well, having issues.


So booted in single user mode, ran fsck, found some issues and resolved them. Go to reboot... Just hangs about halfway up the bar loader under apple logo.

Fun! :)