File Don't Open With Default Application


I just brought up an Xserve with mirroring. The files are all supposed to be kept in 2 separate disks. Now I have trouble opening any files.

It seems that the files lost their default application designation. When I go to "get info", I look at the "Open with" field and it is empty. Trying to reset the pointer to the application, but the application is greyed out in the selection.

How do I reset the field to the correct application?
Ctrl-click the file, select "Open with->Other...". In the dialogue window, deselect "Recommended applications" and select "All applications" instead. Now find the application you want to open, select it and click ok.

This problem is probably due to a problem with one or both of these files: "" in "/Library/Caches/" and "" in "~/Library/Preferences". Trash them and restart, and they should be rebuilt with the correct contents, and your files should open with the right applications again.