File permissions and the drop box.

ericmurphy

Registered
I've encountered one of those annoying things in life, kind of like locking your keys in your car with the engine running. I have my system set up so that users have drop boxes, which other users have only write permissions for. The problem arises when a user drops a file into another user's drop box, when the file has read-only permissions for everyone but the owner. Now, the guy with the drop box has a bunch of files he can't delete (no write permissions), and the guy who owns the files can't get to them to delete them (no read permissions for the drop box). The only way I know of to delete these files is to su to root and delete them from the command line. I've tried changing the permissions from the info window and copying the permissions to all enclosed folders, but that doesn't work for files (and it seems to work inconsistently even for folders).

Does anyone know of a fix or a workaround? I sent feedback to Apple on this; hopefully there isn't any totally obvious workaround...
 

rharder

Do not read this sign.
LOL! That's hilarious. Unless it happens to me.

Of course even modifying the Finder to automatically update permissions that are dropped there won't change anything if files are moved in programmatically from a shell script.

How have other *nix administrators solved this problem?

-Rob
 

Fahrvergnuugen

I am the law!
Good questions. I would also like to know.

Another thing, is it me? or does it seem like the permissions part of the inspector is a bit pre mature? I would guess its not just me since other aps such as xFiles are so popular.
 
Top