File sharing needs to be fixed


I have several complaints about the apple currently handles file sharing in OS X, but I'll start with the stuff that was supposed to work:

I can turn on file sharing, appletalk, etc. on my OS X beta imac, but when I connect to it from an OS 9 mac by using the "Server IP address..." option in the Chooser and give my root login, I just get a blank window. The way I understand the documentation, I should see the Public folder from my user directory. I also tried connecting from my own mac (it let me do this) by choosing "Connect to Server" and entering my own IP address. Again, I saw an empty window-- there were no volumes to choose from.

Can anyone tell me why this would be? Obviously the Appletalk and filesharing options are turned on, because I get as far as being able to choose a volume. But why is the list empty? Is there some other option somewhere I have to turn on? I checked my directories, and their permissions all seem compatible ("everybody" can read everything)

In any case, I think apple needs to do a better job file sharing with OS < X macs. They should support appletalk-- fully-- so that "obsolete" macs can still be used, without having to upgrade their operating systems. OS 8 macs don't seem to be able to connect by AFP at all, as far I can tell!!

Flame aside, thanks for your help--
Don't attempt to log on as root. Instead, log on as yourself. For instance, use the name & password (even if your password is also the root password) you specified when you (the Administrator) setup the computer with Assistant.

Here are some notes that help (from one of my earlier posts):

Use the Multiple Users to create all the users you want to access your computer (this is the same as the Multiple Users control panel AND the Users&Groups tab of the FileSharing control panel in Mac OS 9). All users except Administrator will belong to group "staff". (Administrators belong to "root" as well.)

Log in as one of the users. Open System Prefs, click the Sharing pane, and click Start to make the user's folder shared.

Here's the way it works: For each user, the user's home folder is a share point. For example, Johnny, Sally, and Sue all access one computer. When Johnny logs in to the serving computer and turns on Sharing, three share points are provided from the computer: johnny, sally, and sue. These are folders which reside in ../Users. Now, when Johnny logs in from ANOTHER computer, he can see all the share points. The privileges work as thus: johnny - read/write to every folder enclosed (that's because Johnny is the folder's owner), sally - read only for every folder enclosed except for ../sally/Public/DropBox. Remember, Johnny logged in as johnny; although he can see Sally's folder, he can only write to her drop box. (Works similarly for Sally's share point, sally.) Every user has a drop box by default.
Hi, thanks for your reply-- I had read your earlier post but hadn't thought to try logging in under my "full name".

This worked... the *first* time I tried it. Oddly, though, I got two options-- to connect to my home folder, and *also* to connect to my entire hard disk volume! (I have only one hard disk/partition) I believe I read a post where someone was trying to do just that, but the concensus was it wasn't possible.

Well, my luck was too good to last. I played around a bit, trying to connect to my guest account (which didn't give me any volume options)-- then I started seeing the same problem I saw before: no volume options *even* when I connect through the AFP server, even with my full name.

Any more ideas? Thanks again for your help,
Try stopping then starting Sharing. You may even want to run the Multiple Users app and reset your password. (Then reboot)

If you log in as root to your Mac OS X beta machine via AFP, you will see all volumes. This is because root is the owner of them.