file sharing problems


I have 2 macs networked together. When the G5 restarts it gets hung up trying to log on to the G3. It will start up if the G3 is shut down. If I start up the G5 and then the G3 the G5 can log onto the G3, but the G3 cannot log onto the G5...spinning rainbow parasols. Cannot start up the "sharing" system pref on the G5. any suggestions...thanks
Thank you for your interest in this. They are connected to a router, along with my 2 son's Winboxes. Using os x 10.3.9.
So System Preferences/File Sharing won't activate?

Start with Apps/Utilities/Disk Utility/repair permissions then reboot and try to activate the File Sharing preferences.

Once we get file sharing open and active on both computers then we can try Go/Connect to server to see if we can see the other computer on your network.
I felt that using Unsanity's 'fruit menu' and 'clear dock' which I love, might be the problem because on some forum there was a warning that the APE (Application Enhancer) can cause odd behaviors. This original annoying start up behavior had grown to: also not being able to access the sharing sys pref and not being able to mount the G5 on the G3. Disabling temporarily the APE immediately solved those problems, but the start up difficulty continues, APE disabled or not. I am considering uninstalling the ape altogether because of the other improvements but have not.

I have also just repaired permissions after the above as you have suggested.

I can Go/Connect at will now but I can only start up the G5 if I disconnect the ethernet and plug it back in after startup.

To be more specific, The G5 will start up, but before the drive and the finder are able to mount the connecting to G3 permissions screen pops up. It is not accessible due to the spinning beach ball. I have to use the reset button to restart. I have found another person with this problem on the Apple forums. The suggestion there was look for aliases for each machine on either machine. I have no aliases that I can find.

--[I find that any customization you do to the system (dock or icons, etc.) can make your system act buggy. I err on the side of boring. He he.]--

--[I don't think you have an alias problem but OS X does tend to "remember" other servers and tries to connect to them sometimes on start up, sometimes after start up. I'm having trouble determining your problem because I am unsure of what kind of router you have and also why a machine wouldn't boot up just because of another machine connected to a router. It shouldn't start searching for the other machine until it's booted up.

So, can you boot up each machine separately when they both aren't connected to the network?]--
It actually sounds like you have 4 computers networked together. Could it be the macs and pcs aren't playing nice together?
Ah! When your G5 tries connecting, hit Command + Option + Esc to get the Force Quit menu to come up. Then quit the finder. Hopefully this will interrupt the server attachment routine long enough for you to fully boot the g5.

Is there any more information you can tell me about the router and how the computers are plugged into it? I feel like I'm missing something… :|
I have done alot of restarting and have defined the situation more clearly. Here is a summary of how it looks.

I have a dual 2.0 GHz G5 and a G3, OSX 10.3.9, networked by ethernet to a netgear mr814 router through to the internet.

When I restart the G5 the Finder and the hardrive will not load because the window "connect to server G3" comes up asking for a password authentication. This is accompanied by the rainbow beachball, which prevents input. The G3 does not have this problem.

Circumstances of Problem: Whenever either computer has accessed the other through afp.

What I have tried:
Repaired permissions frequently.
Unmounted G3 from desktop before restarting
Stopped file sharing on G5 before restarting
Stopped file sharing on G3 before restarting
Uninstalled Unsanity "Application Enhancer Program"

I can complete start up only by disconnecting the ethernet cable and force quitting the finder and relaunching the finder from that pane. Or I can disconnect the ethernet before restarting.

So the problem remains just on the G5. It seems to remember any afp activity and looks for the G3 if it is connected to the network on start up.

thanks for lending your brain.