File Sharing w/ PC

moonchilddave

Registered
I am trying to share files from my PC to my MacBook but so far have been unable to do so.

MacBook is running 10.6 and the PC is running Windows XP Home (SP3). Both are connected to my CradlePoint MBR-1000 wireless router.

I am able to see the PC from my Mac under the shared places sidebar. I select the PC, and click on connect. After entering my username and password it shows me connected as Guest which I don't understand. But it lets me in and I can then see the folders that I have shared on it. When I click on a folder, to see the contents, I get the following message:

"The operation can't be completed because the original item for "o2em" can't be found."

I do have the worgroup name of the PC in the Airport settings under the Network preferences. The username and password of the PC I am using is an administrator account.

The system.log on the Mac has the following entries:

Sep 3 21:55:23 daves-macbook /System/Library/CoreServices/NetAuthAgent.app/Contents/MacOS/NetAuthAgent[23742]: smb_mount: mount failed to arcadeclassics/o2em : syserr = Cannot allocate memory
Sep 3 21:55:23 daves-macbook /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder[6167]: NetworkNode::handleMountCallBack returned 12

Any ideas on why it doesn't seem to be allowing me access to the PC? BTW, at first I noticed my firewall on the PC was blocking the traffic so I added an exception to allow all traffic from my Mac.

Someone help... I'm pretty sure it's something not set up right on the PC but I have no idea where to look. BTW, I do not have Windows Sharing enabled on the Mac as I really am only interested in pushing files to and pulling files from the PC to my Mac (not the other way around).
 

moonchilddave

Registered
I enabled Windows (smb) Sharing on the Mac and no difference - and from what I can tell I've got things set up correctly on the PC according to the given article. Same message is appearing in the system.log. The odd thing I notice is everywhere shows the login dialog box with a place to enter the Workgroup name - I do not get that. Just username and password. Is that different in Leopard/Snow Leopard?

I also thought that you only needed to enable Windows Sharing on the Mac if you wanted to use the PC to access files on the Mac.
 

co19

Registered
In most cases you have to set specific files to be able to be shared across your network. If you dont set anything and you try to mount it using SMB nothing will show up.
Here's how you do it:
1. Go on your windows, and choose the directory that your mostly going to share
2. Right Click
3. 'Sharing and Security..."
4. Go to the sharing tab
5. Click the underlined words; "If you understand the risk but still want to share the root of the drive, click here."
6. Then under "Network Sharing and Security" check the box "Share this folder on the network"
7. Either keep the name or give it one
8. Hit Apply and try to mount it again on your mac, you should see that file.

Note: If you want to be secure, only do this for your shared folder or wherever your files that you want to share are in. But if you want to just have easy transfer and your network is WPA encrypted you should be fine.
Also, if you want to edit files from your mac then check the box "Allow Network users to change my files"

If these options aren't popping up, configure your windows firewall or just turn it off, including any other firewalls.

If all else fails, use a program. Google will help you with that, but if you dont want to, here's one thats not bad: http://www.purenetworks.com/mac/
 
Last edited:

moonchilddave

Registered
I have set up the sharing on the PC correctly, as you stated. I think the odd part is I am not given the option to enter the workgroup name on the Mac (although it is in the Airport preferences) and the other puzzle piece seems to be why it takes my username and password but shows me connected as Guest? I actually have the Guest account on the PC disabled (and I'd prefer to keep it that way).

BTW, my network is WPA2 with a 163 random character password and the signal strength turned all the way down so you can't connect from outside the house. The router is also configured to only allow specific MAC addresses to connect - so I'm pretty sure my network is fairly secure.
 

co19

Registered
That part is actually not odd at all, it's a very common error with windows XP and OS X 10.5-6. I have the exact same problem, but after I enter the username password, it still says guest but I can see all the files I set to shared. Both my macbook pro and my windows are not on the same workgroup so I doubt that is the problem also.

The main problem in trying to help you right now is that it could be lots of misconfigurations and I have never seen your error message before. I can guess you have probably tried many options, the only last thing I can suggest is making your PC the least secure as possible and then connecting. Also, try taking down your WPA2 security settings for one moment and try connecting, I know it seems odd and looks like it has no affect, but you really have very little to lose. There's no secret black ops hacker in an unmarked mini van outside waiting for you to turn off your encryption settings :p

Last thing, i have pretty much the same setup as you and I can connect to my PC, if you would like to ask if I have any preferences turned on/off I would be glad to answer them for you.
 

Satcomer

In Geostationary Orbit
Also what has seemed to help some people (in Domains of course) is to use the same Time Server in both machines. It may not hurt to try this.
 

moonchilddave

Registered
Also, I was correct in my assumption that Windows Sharing does not need to be enabled... It works without it turned on. I would only need Windows Sharing turned on if I wanted to access my Mac from the PC.
 

foto gwaii

Registered
I really appreciate you taking the the time to post this.

It was driving me nuts and after many hours searching for a solution your post solved it for me

Again THANKS !

All the best
 
Top