File sharing with XP and 10.1

theCaptain

Member that enjoys Meece
Can someone give me some tips as to how I could go about file sharing between Windows XP and Mac OS X.1 !:)
 

Yeeeeeeha

Registered
I've only got it to work from X.1 to XP.. not the other way.. may be a pathing problem..

Without setting up anything special on either machine open the network browser in X and type:

smb://machinename/shareddocs

you should be promped for a domain, user name and password.

If anyone can answer how to mount the public folder on X from XP that would be great.
 

theCaptain

Member that enjoys Meece
I try to do it but I always get an error message back saying "No file services are available at the URL...." what could I be doing wrong, are you sure I dont have to make a changes to my XP PRO machine?
 

Alexis1537

Registered
The code for connecting to a Windows 2000 Pro machine (I don't know about XP yet, but it SHOULD work) is as follows:

smb://<network domain name> (usually something like "workgroup");<username>(as specified in "Users & Groups" under Windows - NOT Mac OSX's "Users"!)@<name of PC you are connected to> (see ID tab under "system" panel)/<name of shared drive>

So for example, to connect to my PC's MP3 partition I have used the following code:

smb://workgroup;alexis15@server/mp3s

"server" is the name of my Windows 2000 PC. In "Users and Groups" I specified that "alexis15" would want specific access to my F drive (the MP3 drive). I created a new share in "My computers" and allowed "alexis15" to access that drive. Creating a share allows you to give a name to your F drive (e.g "MP3s").

You will then me prompted to enter the password you specified in "Users and Groups". For my backup drive (a renamed E Drive), the code is therefore as follows:

smb://workgroup;alexis15@server/backup

Again, you will be prompted to enter your password to access that drive.

Any questions, let us know.

Best regards,

Alex
 

theCaptain

Member that enjoys Meece
I am having no luck. Thank you, all, for assisting me. My mac doesnt even seem to searching for the address that I enter for my XP machine it just immediatly comes up with the error message stating that Thier is no such address with this name. Any more suggestions? :(
 

Alexis1537

Registered
Originally posted by theCaptain
My mac doesnt even seem to searching for the address that I enter for my XP machine it just immediatly comes up with the error message stating that Thier is no such address with this name. :(
OK, usual question time.

- have you connected the two machines with a cross-over cable (if a peer-to-peer network), or a patch cable (if connected to a hub)?

- If so, have you ensured that the network adapter on the Windows XP machine is functioning correctly and recognising the fact that a network exists?

- Have you set the PC's IP address correctly? Usually, it should be set as 192.168.0.1 (for the Network adapter connected to the Mac/Hub).

- Have you set your Mac's IP address as being 192.168.0.2 (under "Network setting", connected via DHCP w/router)?

If the problem persists, let me know.

Best regards,

Alex
 
Top