Finally solved annoying DNS lookup failure messages


Is anybody else getting those annoying dns lookup failure messages in their console?

May 10 09:17:06 dsl-64-130-121-97 lookupd[165]: DNSAgent: dns_read_reply - bad query
May 10 09:52:43 dsl-64-130-121-97 lookupd[165]: DNSAgent: dns_send_query_server - timeout for

I think I might have finally tracked it down yesterday... I am getting my interent connection through a linksys router, and I also have an Airport setup with NAT, so my Mac is referred to by at least 2 different private IP address, which I believe was confusing lookupd. I am running sendmail, and by using the debug options noticed it was choking seriously when trying to do reverse dns lookups on those private IPs, taking 20 or 30 seconds for each before failing... so I figured this might have something to do with the problem.

First, I put my router IP address ( in the hostconfig file (replacing -AUTOMATIC-). Second, I added all the ip addresses that my machine could be referred to into NetInfo under /machines (ie., [airport], etc.). You can add multiple values via one of the menu options. I added the values to a record that I believe I originally created by copying the localhost/ record, and changing the values (don't quote me on that). Finally, I made sure that I listed only 1 dns server in my linksys router settings (don't remember where I heard about this...), and I believe I also cleared out the dns setting in the Network System panel, letting it instead pull down the address itself with DHCP. Remarkably, something out of all of this seems to have worked...

I'm still a little unclear about which steps were necessary, and which ones were not, so if anybody learns any more about this, I'd be interested to know.