Find is slow, which is causing dramas!


Hey people! Before the SEARCH flames ::evil:: start I just want to say I've tried 10 times to search and it just sits there on search.php and times out! So I'm just going to do this the old fashioned way:

I have a dual 1ghz Quicksilver 2002 G4 with 10.3.9 (all updates, legit install) and everything works a charm appart from when you hit find it takes a couple of minutes of doing nothing and then all of a sudden the results rush in. Now this isn't a major drama - but I'm also trying to install Creative Suite CS on there and it gets to the point where it reads "searching macintosh HD" and then hangs (I've even left it overnight).

Would the existing search engine be corrupt or not working? Would this be affecting other programs that might use it? (installers etc..) and is there any way to fix it! It's a fresh install of 10.3 too, and I've tried the same thing on my G3 400 running same OS and not a problem at all...

Incase this is related at all: I also can't safe boot.. if I hold down shift then take it off when the wheel starts doing it's thing under the grey apple, the computer thinks for a bit then just reboots it'self again.. odd!

Any help is greatly appreciated, and like I said: I tried to search! :D
It sounds like you need to run Disk Utility.
Start up with the OS X CD (matching the version you are running) - insert CD, restart the computer and immediately hold down the C key.
Do not click on the installer screen. Instead go to the Installer menu (at the top of your screen)and select Disk utility.
When that opens click on the second icon in the side bar at the left, then click on Repair Disk at the bottom right.
Watch the activity screen. If it does any repairs - you will need to click on the Repair Disk button a second time after the first pass is done. The object is to make sure it finds all the problems and repairs them. You may need to hit that button a third or fourth time to get no references to repairs made.

Now click on Repair Permissions.

When that is done, quit Disk utility and restart the computer. Give it a test run.