finder crashes/restarts every 100 sec or so..

darcy

Registered
I have been running 10.1 without a problem for about 3 weeks, but yesterday the finder started freaking out.

Everything else still works, but any work the Finder is doing will stop (copying, browsing) and the desktop will switch back to the default blue and the icon will bounce 3 or 4 times until it is all restored. (crashes and then restarts)

If you are copying something, it seems that it will take longer for the finder to crash, sometimes up to 5 minutes (if copying a lot). But then it might crash in the middle and omit copying the rest.

What seemed to trigger this was when I was copying CodeWarrior to the OS X startup drive, which is about 11,000+ files and 770mgs. Also had just mounted a disk image and trying to copy the files from that onto to the OS 9 drive. All this while simultaneously streaming iTunes music and surfing the internet.... gotta love it.

Now, it doesn't seem to matter what is running, it will just crash every 100 secs. Classic running or not, no mouse movement or any finder interaction still yields the same thing, in fact it will crash even when the computer goes in the screen saver. I don't let the computer go to sleep, haven't tested that.

Restarting the machine doesn't help.

Ran Drive 10 utility (version 1.0.1) and everything passed up to the final test Volume Structure which seemed to just hang.


Any help would be greatly appreciated as this is driving me nuts. will be forced to reformat in a couple of days if nothing helps.

Attached is a file that contains the contents from the Finder.crash.log which contains 2 Finder crash/restarts and the contents from the /var/log/system.log on a boot up.


Thanks,
darcy.
 

Attachments

darcy

Registered
it seems the problem has decided to unposses my machine. the finder had gotten to a point where it would even start itself back up when it crashed, you had to do it yourself. this actually proved to be a good thing since i had work to do and all the other apps worked.

not sure what fixed it exactly, but here is what i did that seemed to bring it back to life.

1. moved the CodeWarrior 6 folder i had copied over (which might have been what started the whole problem) to the Trash.

2. installed CodeWarrior 7 where 6 was copied. the installer quit all the other apps to begin installation and when it finished installing, it then started the finder back up. which hasn't crashed since.

3. stomped on the floor and screamed out load, which possibly shook drive.


hope this helps someone out there.
 
Top