Finding Alternate Superblocks


I have a problem in that fsck won't run on my X device when booted into single user mode. However, I can boot in single-user off the X CD. Then I run fsck on my /dev/disk0s6 and it tells me the Super Blocks are bad. When I tell it to go look for an alternate, it can't find one. Not too smart. i read on a TIL post that 16 is one alternate, but using the -b switch which tells fsck where to look for the alternate comes back with Wrong Magic Number. Does anyone know where to get a list of Alternate Super Blocks?
Interesting note: I am booted normally into my X partition right now, without error messages. however, DFA says there extent problems it can't repari.
Awaiting the crash.
The next superblock should be at get a list of all superblock backups, use

sudo newfs -N /dev/rdisk0s6

(or whatever for 0s6). This'll print out a list of the parameters used for that particular filesystem (the -N doesn't actually create a new filesystem).

Note, however, if your partition being checked is HFS or HFS+, you might try fsck_hfs first; I've always had to run it that way instead of just fsck when in single user.
Thanks for the info. I had previously tried to force 32 as the alternate block, but fsck said wrong magic number. I was loathe to use Norton, but tried it. It pointed out some temp111* files in /Private/HFS+ which were messed up. One file, the system thought was 159 Gigs. I was nervous about deleting these, but they did seem to be temp files and there were others like them. Clearing the two that Norton kept choking on has relieved the DFA errors and fsck with your hfs addition, says all is OK.
Having said that, the 10.0.4 update may be the reason my classic apps fail to open and save files. Looking into that problem now.

In Sum: Norton Fixed bad superblocks?!