Firewire Port Messed Up After Firmware Update

waspking

Registered
I found a firmware that supposedly would make the original superdrive (1x) of my titanium G4 powerbook (15", bought Jan 03) faster (become 2x, see http://superdrive.cynikal.net/).

so I updated my firmware using first "UJ-815 to DWDB", then "UJ-815 to DOCB" and the computer boots up and seemed to worked fine.

Then I connected my 40 gig firewire drive and it reported "mac os cannot read this disk, do you want to format/ignore", clicking ignore the disk mounts but cannot be written into and read (icon spins and computer gets stuck). I tried a 160 gig external firewire drive, no message at all.

I tried a few more times with the 40 gig and the message appeared twice but became readable... the problem is my 160 gig seems to be dead! it cannot read by my iMac G5 or my G3 B/W. Disk utility does not see it. I wonder why my mac would kill one and not the other. I have had no problems with either Mac with these two drives. Glad that I only backed some data recently from the 160 gig.

It appears that I followed some wrong directions (on a different page), changed the firmware to a 17" one (DWDB), then flashed the original apple firwware back (DOCB)... but it does not explain the mess up of firewire. Now I flashed the correct firmware (firmware_uj815_D101). however even the 40 gig external firewire drive stopped working...

My powerbook g4 has OS X 10.2.8. and G5 has 10.3.

Thanks.
 

waspking

Registered
well after a while now my G4 Powerbook can read my 40 gig now. but still no luck with the 160 gig with either computer. I plugged it through USB today and now I get a message saying OSX cannot read it and recommend reformatting... disk utility can see it now, but cannot fix the error. so there is hope, but my data might be all gone. is disk warrior worth the money?
 

Viv Horwitz

Registered
I am hving similar (not the same) problems with external firewire disk - I have tried the workaround which says - 1) power down computer and external disk 2) unplug EVERYTHING including mains plug 3)leave for 30 mins then plug in mains, startup comp then plug in peripherals then plug in firewire and start up firewire disk this works ok provided comp does not then go to sleep (buggers up firewire recognition)
might bring back the fireiwiredisk but doesnt solve overall glith with firewire and sys 10 (.1,2.3 & now 4 - I think apple needs to sort this one OUT!)
regds
Viv Horwitz
 

waspking

Registered
Since USB can see my drive but not mount, I bought disk warrior last night and started repairing it. Now it mounts fine. However it does not get recognized by firewire! strange.

it is ok with me since my iMac G5 recognizes it as USB2, but strangely my powerbook G4 only as USB1 (but the huge difference in speed of transfer: 250 meg in 10 seconds on G5, but 10 min on G4).

how do I make my G4 to see it as USB2? Neither does my G4 recognize it as firewire either.... Disk Warrior does not detect it if I plug it in as a firewire... interesting problem...

WK
 
Top