Firewire Won't Unmount



My LaCie Firewire drive won't unmount and I can't copy any files to it. The problem started when copying a file into iTunes and now when I try to unmount the drive I get the message "Firewire is in use and could not be ejected. Try quitting applications", but I've no applications open. I've tried force quit, relaunch finder, logging out, restarting, etc. The only way I can eject it is hdiutil eject -force.
I tried fstat | grep diskname but it didn't show the Firewire drive.
When I run the command ps -aux | grep iTunes I get...
user 406 6.0 0.1 18172 344 std S+ 9:59PM 0:00.02 grep iTunes
When I try kill 406 it say No such process, then when I run the same command again the ID has changed. I'm running OSX 10.3 on a B&W G3.

Any help would be greatly appreciated.

Hmmm. This has happened to me before on various occasions. Restarting always did the trick for me. Run the Apple disc utility or Diskwarrior/Techtool Pro 4 if you have them. Try shutting down and then turning off your hard drive as a last resort.

What type of file were you putting into iTunes out of curiosity? If it's a file that is being used by another part of the OS that would explain why it's giving you the "app still open" message.
Hi there
My iTunes music folder is on my Firewire drive, so when I import a CD it's copied to there, the problem started when iTunes crashed whilst importing. Eventually I did have to shut down and turn off hard drive, which in hindsight probably didn't help things!
But the drive works fine on a friend's G4, and is also ok when I boot up in OS 9.2.2 on my partitioned internal drive, so I'm guessing it's a problem with OSX. I ran the disk utilities you mentioned with no luck.
Thanks for your help.

I have had a similiar issue appear yesterday on my Dual 2.0 G5 running Tiger after I moved my iTunes music to my Fantom Firewire Drive. To make things worse i then copied the entire contents of the drive to my fibre channel raid and it now won't unmount. I am now at a grinding halt where opening any files from either external drive takes 3-5mins for a 1.2mb file.

I get the same message about being in use by an app (nothing is open) when trying to unmount it. I did see the error message "-50" pop up once when doing a save to the firewire drive.

I have restarted, reset PRAM and NVRAM tried to use Disk Utility no luck.

I don't have tech tool yet but I am at a loss on this as well. I wonder if it is itunes related thing?

I am going to try mounting/unmounting the drive to my Pbook.

Just to update my last post. After just pulling the plug on the Firewire drive and getting the Device Removal warning I was able to mount, run Disk Utility Repair on it. Which indicated a minor header issue.

It now runs absolutley fine on my powerbook, no lag, no slowness and it mounts and unmounts fine.

It still won't run properly on the G5 and my fibre raid is still acting up. This is so weird.
To further update the progress: I thought to myself let's trash iTunes and see what happens. HAHA!

It wouldn't becuase "itunes helper" is running. Well what the heck is that? type it into spotlight, find it's preference list (trash it and all the itunes preferences while you're there) Now trash itunes, oh you can't becuase the helper is still running (which must be a hidden app - cuase you can't find it anywhere)

I backed up my music files only, got rid of the library and ALL iTunes associated files, dragged the itunes app the the desktop, logged out logged back in. Dragged itunes into the trash and BOOM! it's gone.

Crazy you think? well I got ALL my drives back in normal working order. They mount unmount and I can open files and save files as before.

May APPLE needs to fix their little helper app cause it SUCKS!

hope this helps you out


They were working fine. But now they are still having problems.

I don't know WHAT is still running in the background. Nothing is open. It won't unmount and we are back at turtle pace....
This thread may be dead? But my Mac is not.

Reformatted external drives (Firewire and Fibre Raid)
Archive and Install Tiget again
DID NOT DO 10.4.2 update
iTunes 4.9 works fine!

All back to normal and working peachy