(fixed) External Boot Drive + Boot Camp = Dead Computer?

snorq

Registered
Hi. Not sure if this is more of a software or hardware issue, but thought I'd try here first.

I have a mid-2011 iMac 27" whose operating system (Yosemite) and all the boot files and such are stored on external SSD connected via Thunderbolt. The iMac's internal HD is just used for storage.

All was fine, more or less, until I tried to use Boot Camp to create a Windows partition. I say 'more or less' because it had been showing problems with hanging (white screen) during restarts the past day or so. Anyway, I created a Windows partition on the iMac internal HD (the only option I had), after which the computer immediately restarted (with no warning, so maybe it actually crashed, I'm not sure). After the computer switched off and then back on, it hung again on the white screen. I turned it off (long press on the power button) and then on again, got the white screen, waited a bit, and then the screen went black and I got some DOS-like text saying something like 'No bootable device -- insert boot disk and press any key". Pressing keys didn't do anything.

So, I'm guessing that something got screwed up during the creation of the Windows partition, such that there is now nothing telling the computer to look to my external SSD for the OS and boot files. However, I have no idea how to fix it.

Any help would be greatly appreciated, because right now my iMac is just a giant paperweight, and fixing it is beyond my skills.

Oh, I've tried pressing Option and Shift and other keys to get to the startup/boot menu (or whatever it's called), but that didn't do anything.

Thanks in advance.
 

snorq

Registered
Nevermind. I was able to get in via Command + R (something new to me), and then select the startup disk.
 
Top