floppy drive and mount command

kilowatt

mach-o mach-o man
So the word from Apple is that you can't use your internal floppy drives with Mac OS X. Well, I beg (plead) to differ.

I can't figure out the mount command (I'm used to I guess the gnu version, which is on my linux/x86 box).

I also can't figure out where the floppy drive is in the /dev directory.
I'm used to something like /dev/fd0 .
In X, I see a directory, /dev/fd/ .
Within /dev/fd, there are 3 'files' and two directories. I can't cd into the two directories, and the three 'files' don't cat anything.
(on my linux box I can cat /dev/ttyS0 to see raw serial data, for example).

There are alot of unix buffs on this board, and I know we can figure this out if the kernel supports the floppy drive (like how the kernel supports my beige g3's serial ports, even though they arn't supported officially).

Thanks!
 

ladavacm

Unperson Spotter
No idea about the floppy, but the /dev/fd is a file descriptor pseudo filesystem, and has nothing to do with floppy.

Since Mac OS X uses a form of DEVFS, the recognized devices show up in the /dev. There is no need to mknod them. So, I would not be surprised by the fact that OS X does not allow to mount a floppy because it does not support it in any way.
 

davidbrit2

Licensed Computer Geek
Did Apple just decide not to have floppy disks auto mount, or is there actually no code behind Darwin for interfacing with the floppy controller hardware?
 

kilowatt

mach-o mach-o man
...lte me put it to you this way:
if you insert a floppy disk into an internal floppy drive, you better get that stgraightened paper clip ready.

Yes, apple does not have the floppy drive automount, and nothing about the OS seams to support it. Too bad about that. Even YellowDog Linux supported my floppy drive.

But honestly, how much trouble would it be for App(l)e to compile floppy disk stuff into the kernel (thats what needs to be done, right?).

I think thats just plain old lazyness. Even if it was buggy, they could at least support it via command line (not aqua).

I'm ticked off.
 

davidbrit2

Licensed Computer Geek
If you really need a floppy drive, the LS 120 USB drives seem to work. But they are very slow.
 

davidbrit2

Licensed Computer Geek
Sooner or later, someone will probably write something to use the built in floppy drive. I would think that you would just need a kernel extension to support the hardware, and then put the necessary device file into /dev. I would do it myself, but when I try to program in C it's kind of like the "thousand monkeys with typewriters" analogy.
 

kilowatt

mach-o mach-o man
True, apple does have a bazillion better things to do.
I for one would like to see the finder made multi-threaded. The only reason apple gets away with the current finder is the semi-steep system requirements, such as 128megs of ram (which is really not enough in my opinion for a speedy desktop).

ok, enough ranting.

Yeah, programing in C is alot like the monkey aphorism for me too.
I don't mind php, perl, python, etc. But C is.... well... different. Powerfull, but, well, non-intuitive. I whish I knew it though. I can program in M$ Visual Basic like mad (as well as Real Basic), but C is just beyond at the moment.
 

davidbrit2

Licensed Computer Geek
Yeah, VB is definitely cool for throwing something together quickly. I just wish it had some better low level features so I could more effectively make things like games. Still, it's either that or QBasic, so I guess I can't complain.
 

endian

Dis Member
Apple is itching to drop support for the only OSX-compatible Macs to have floppy drives (beige G3s) so I expect that to happen before Apple adds floppy drivers just for them
 

genecutl

Registered
I tried connecting an external USB floppy drive on the off chance that it would work and,
what do you know, the floppy showed up on the desktop. I was very surprised considering
that this thing needs extensions to be loaded on the OS 9 side to work.

However, it wasn't without its problems. I tried renaming the floppy in the finder. The
new name appeared, but the floppy suddenly appeared to be empty. Looking in /Volumes/,
I saw the original name with all the files still inside. Must be some miscommunication between
the Finder and the OS. I ejected the floppy and put it back in, and it appeared again with
the original name. When I tried a different floppy, it didn't show up, nor did the original after
that. In fact, something got seriously screwed up, because a server I later mounted wasn't showing
up on the Destop either. Trying "Connect to server..." again reported that it was already connected.

Bottom line, it sorta kinda worked in a flaky unreliable way.

The end.
 

frooyo

Registered
try the following command:
mount /dev/fd0 /mnt/fd0
or
mount /dev/floppy

Hopefully this works for you - even so, I still do not know how you can get the disk to eject the disket without pushing in the releash button with a paper clip. If the command is succesful - you can access the disk at /mnt/fd0 or /mnt/floppy.

Good luck
 

kilowatt

mach-o mach-o man
frooyo, that was the first thing I tried, I guess we both have a strong linux background.

In macosx, the floppy doesn't currently have a /dev entry, so there is no /dev/floppy or /dev/fd0. There is /dev/fd/, but the fd directory is some sort of fake file system that I don't understand.



Too bad about the Cube. Oh well, we all knew it would happen. sob sob sob.
 

AdmiralAK

Simply Daemonic
with no disrespect meant towards floppy users ;)
but what kind of mac person uses them any more ?

I mean PC people bitch and moan about the lack of a floppy but even when I had a floppy on my performa, when I went to college and needed to transport stuff, the floppy was useless and SLOW. I would not transport anything lol. The floppy is dead :)

(I am suprised how PC people gave up the 5.25" disk drives lol :p)


Admiral
 

Zim

Registered
Just as a datapoint,

on Solaris you insert a floppy and type

volcheck

then you can cd /floppy/ and go from there.

May not matter without enuf OS support.

Mike
 

kilowatt

mach-o mach-o man
I guess os x lacks that program. I couldn't find it.

However, I had been wondering how to mount floppies on my SPARCstation for a while, so thanks for the info (I've had my sparc for about a month now).
 

TommyWillB

Registered
My VST USB Floppy Drive (a TEAC mechanism) works just fine. I've never even had to consider drivers. It has worked ever since the public beta... and it is not very expensive.

I too will admit that reading/writing is slow, but that is why I'm trying to get my Mom used to sending email attachments instead of US Mail floppies... We are getting there slowly.
 
Top