Follow on Apache, and now FTP

jabhome

Registered
OK, I apologize, I am a moron, it is now working. If anyone is having a problem starting apache as a user rather than root, maybe this will help. Once again I am sorry for taking up this space. As I kept revising this message I got it to work, lol :D

OK, so when I am log in as root and enable Apache through the System Preferences panel, everything starts up just fine. The whole word is able to see my files. However, when I log in as username, and attempt to start websharing through the same system preferences, it locks up. So I figure I will use su root, then apachectl start, but when I test 127.0.0.1, I do not see any files, which means no one else can see them as well. Can I only use web sharing when logged in as root.

I have used the apachectl configtest command from the terminal while logged in as username, and everything checks out, apachectl start works just fine, and httpd is started. But starting web sharing through system preferences is a no go.

Any thoughts,
Jason

By the way, here is the command line after the test and start commands

[localhost:~] ibook% apachectl configtest
Processing config directory: /private/etc/httpd/users
Processing config file: /private/etc/httpd/users/guest.conf
Processing config file: /private/etc/httpd/users/ibook.conf
[Thu Sep 13 20:59:52 2001] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
Syntax OK

[localhost:~] ibook% sudo apachectl start
Password:
Processing config directory: /private/etc/httpd/users
Processing config file: /private/etc/httpd/users/guest.conf
Processing config file: /private/etc/httpd/users/ibook.conf
[Thu Sep 13 21:03:14 2001] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
/usr/sbin/apachectl start: httpd started
[localhost:~] ibook%


Is it a problem with the guest.conf or ibook.conf files
 
Top