Font handling


My install of OS 9 uses Adobe Typoe Manager Deluxe, which means most of my fonts don't live in the Fonts folder in the System Folder, but rather in a folder called (coincidentally) "Fonts" at the Root of my hard disk. After I installed OS X PB, I wanted to move some of these (Type 1) fonts into my OS X fonts folder. As far as I can tell, there are at least two places fonts can be under OS X: in the /Library/Fonts folder, and the /Users/<username folder>/Library/Fonts folder. First I tried dragging a selected group of fonts into the /Users/<username folder>/Library/Fonts folder, and was told I couldn't because the fonts couldn't be modified. This didn't make sense, because these fonts were not activated by ATM Deluxe. But eventually I was able to move them (unfortunately, I can't remember what made it possible). But it was an exercize in futility anyway, because X doesn't recognize them, not even after a reboot.

So next I tried moving this same group of fonts into the /Library/Fonts/ folder, and again got a message that I couldn't move them (why does this behavior remind me of Windows?). But I'm wondering if I'm missing something here anyway. My understanding is that X should recognize fonts stored in either location, to say nothing of fonts stored on a network drive.

Does anyone know what's going on here?
I figured it out. Or part of it anyway. You can't move fonts into the /Library/Fonts folder unless you have permissions set to allow you write access to the folder. Permissions are set to read-only for everyone but root by default. So you can either change permissions (probably not a good idea, considering the problems with corrupted fonts under OS 9), or drag 'em in there as root.

Still don't know why the system doesn't recognize them though.
Well I just copied over a font from my Mac OS 9 to /users/nate/library/fonts folder and it worked just fine. I brought TextEdit up right after and the font was there. Although i believe it was a truetype font.