foobar in IRC username

Isando

Registered
I compiled the irc client Epic last night, and noticed that I ended up with a user id of 'foobar.' For instance, when I whois myself I see 'foobar@my_ip_address.' No matter what I do, I cannot get rid of the 'foobar' and replace it with what I need it to say.


I thought it might be a default setting in Epic, so I fired up ircle in Classic mode, and found the same problem. Setenv IRCNAME and IRCNICK do not resolve the problem either.

Anyone know why this is happening, or how to fix it?
 

Isando

Registered
The problem was with the identd I was using, called nullidentd. Its a lying identd, but it had 'foobar' hard coded into the source. I just changed it to what I needed and recompiled. Problem solved.
 
Top