FTP -- not working -- Help

AndyB

Registered
Hi --

I suddenly cannot connect to my mac running OSX PB via FTP... I try to connect to the computer via ftp and it tells me illegal option -a (I'm using Transmit -- I have also tried using WS FTP LE on Windows 2000 to connect to the computer and it gave me a different error).

FTP access is checked (on) in the control panel...

Both methods were working earlier today, but stopped after I uninstalled Tenon iTools for Apache... the webserver runs fine... I can access the computer via Telnet just fine -- I just cannot access it via FTP -- WHY?!?

Is there a setting that could have been altered by uninstalling Tenon's iTools...

Is there a file called ftpaccess? Where is it located? I'm accessing the computer from home so I can't run Sherlock to find it.

Please help me, I really need to access my work computer from home via ftp...

Thank you very much,

Andy

[Edited by AndyB on 12-02-2000 at 07:16 AM]
 

The DJ

Registered
Originally posted by AndyB

I suddenly cannot connect to my mac running OSX PB via FTP... I try to connect to the computer via ftp and it tells me illegal option -a (I'm using Transmit -- I have also tried using WS FTP LE on Windows 2000 to connect to the computer and it gave me a different error).
Can be lots of things.
First you can not login to OSX as a root user. remember that.
ftp-deamon can have been struck by that 0k bug-thing
Your PATH is screwed and cannot find ftpd.

But most likely i think something in your /etc/inetd.conf file went wrong because of the uniinstall
The upper part should look something like this:
Code:
#
# Internet server configuration database
#
#       @(#)inetd.conf  5.4 (Berkeley) 6/30/90
#
# Items with double hashes in front (##) are not yet implemented in the OS.
#
#finger stream  tcp     nowait  nobody  /usr/libexec/tcpd               fingerd -s
ftp     stream  tcp     nowait  root    /usr/libexec/tcpd               ftpd -l
#login  stream  tcp     nowait  root    /usr/libexec/tcpd               rlogind
#nntp   stream  tcp     nowait  usenet  /usr/libexec/tcpd               nntpd
#ntalk  dgram   udp     wait    root    /usr/libexec/tcpd               ntalkd
#shell  stream  tcp     nowait  root    /usr/libexec/tcpd               rshd
#telnet stream  tcp     nowait  root    /usr/libexec/tcpd               telnetd
#uucpd  stream  tcp     nowait  root    /usr/libexec/tcpd               uucpd
#comsat dgram   udp     wait    root    /usr/libexec/tcpd               comsat
#tftp   dgram   udp     wait    nobody  /usr/libexec/tcpd               tftpd /private/tftpboot
#bootp  dgram   udp     wait    root    /usr/libexec/tcpd               bootpd
##pop3  stream  tcp     nowait  root    /usr/libexec/tcpd               /usr/local/libexec/popper
##imap4 stream  tcp     nowait  root    /usr/libexec/tcpd               /usr/local/libexec/imapd
Hope this helps
 

AndyB

Registered
The error I was getting "illegal option -a" was explaineright there in the inetd.conf file...

On the ftp line, it ended with "ftpd -l -a" in my file and the one you showed me had just "ftpd -l"

Also, I was showing "/usr/libexec/ftpd" in my file where yours said "/usr/libexec/tcpd" I changed it to tcpd...

Everything works great now! I can access my computer now by ftp.

I had to restart remotely as well to get it to work since I am not at work where the computer lives:

shutdown -r now

Thank you very very much!

-Andy
 
Top