ftp & telnet slow to connect

HardyMacia

Registered
I'm tyring to ftp and telnet from a OS 9.1 powerbook and WinME machine to a OS X iMac. All are on a private network in my house where I have an Airport base station acting as a DHCP server to assign IP numbers.

I ftp to the correct IP for the OSX machine, but it seems to take 30 seconds before I'm given the username prompt.

Ditto with telnet.

It seems like Mac OS X is starting up the ftp and telnet services even though they are already running. Also, I don't think either service takes 30 seconds to actually start up. What gives?

Hardy
 

Hi-Fi Guy

Registered
I want people outside of my home network to be able to FTP in but have not had any luck. I have a static IP or I can use a router that has DHCP but no luck.

Any help appreciated.
 

Red Phoenix

Registered
I have had this problem, but with a little variation in the setup. I fixed things after I realized that computers _not_ on the internal network were connecting much faster. What happens is the MacOS X ftp and telnet servers are trying to find out the DNS names of the people connecting. Since you are on an internal network, you almost definitely have no names for them. Therefore we need to make up some names for it

The difference in how we both have our network set up makes a difference. I actually get my Internet connection through my fiance's ME machine running WinRoute (and look up DNS through it, too). I have given my MacOS X computer bogus names to make it happy by I editing the host file on the ME machine (whenever the ftp or telnet server ask the ME machine for a name, the ME computer immediately gives the bogus name and everyone is happy).

In your case, I do not think that it is that easy. As far as I can tell from reading Apple's TILs, one cannot use an airport as a DNS server, let alone edit a host file on it. Anyone who knows better please correct me if I'm wrong on how to do this, but I believe this means you will need to use NetInfo Manager in your /Applications/Utilities folder and enter in bogus names for each computer on the internal network that you are trying to connect with. Unforunately, I am not completely sure what the settings need to be, and cannot help you any further than this. It would appear the change needs to be in /machines/, but I do not know the settings well enough. I hope someone can take it from here.

The other option would be to not have ftpd or telnetd check for names, but I have no idea how to do that, either.
 
Top