ftpd: illegal option

iamnoel

Oh no!
I've got an issue getting ftp to open for me. I've got it on & if I go to log into it I get the following:

'ftpd: illegal option -- a'

I've looked for info on this, & the impression I've gotten is I'm the only one it's occurring to. I'd be very grateful for any info...

Noel
 

VGZ

Registered
How are you trying to log into it? It may be a problem with the method your using.





The other possibility is a problem on the daemon's end. On Mac OS X the ftpd is only launched when someone tries to log in to the ftp server. There may be a problem with your install. You can probably get a new version of the ftpd from one of the gnu sites out there.
 

VGZ

Registered
Ignore the question at the beginning of my post. Your second post wasn't visible while I was typing. It looks like your ftp client is sending an unknown option to the server, but don't quote me on that.
 

iamnoel

Oh no!
I'd originally gotten that opinion, too; only I get the "ftpd: illegal option -- a" in Terminal (i.e., it's not only a Vicom issue). & Interarchy isn't opening it.

One idea I had is that I installed Tenon's iTools, & then uninstalled it (I've got OmniWeb & I guess it's incompatible, one with the other). It is no longer installed, but I guess I ought to be open to the idea that this issue is a leftover of that installation. Otherwise, I'd be very grateful for any other insights...

Noel
 

iamnoel

Oh no!
Ok, I guess...if it's of interest, the version of etc/inetd.conf I've got had this line in it:

'ftp stream tcp nowait root /usr/libexec/ftpd ftpd -l -a'

I got the -a out of there, & now it lets me in. The issue I've got now is I'm on 100Mbps & getting a list of files (i.e., 'ls' in Terminal or via an ftp client) is not occuring, or it's taking too long. One or the other...it fails, or I give up. I've got no ideas on this one, & there's no info on -l. I guess I'll look further into this, but I'd be open to any ideas. ;)

Noel
 

iamnoel

Oh no!
1 other thing: I'm getting the following output if I give it long enough in ftp once I've telnetted outside of the LAN & ftp'd into it:

"ftp: connect: No route to host"

Noel
 
Top