G4 Installation Problems

Razor Blue

I have a G4 500Mhz with 256Mb ram and 30Gb hard drive. I'm unable to install applications from CD or Apple's website. I've wiped the hard drive clean and did a reinstall of the OS, but no luck. I ran Disk Utility, Diskwarrior, and Tech Tool without any success.

Please help.
How about going to Applications-->Utilities and running Disk Utility to Repair Permissions?

If this doesn't work, then try restarting the Mac and hold down the S key for single-user mode. Follow the directions that are listed once you are at the command prompt. FSCK will fix any errors that are there. Once it completes, type "exit" and it should begin booting into OS X again. Once in, try and launch Disk Utility again and Repair Permissions if it opens up.
I ran the Disk Utility to Repair Permissions. I booted into single-user mode and followed the directions and got a "Bus Error." What do you think is the problem...a bad motherboard?
I replaced the ribbon cable and ran "FSCK", but I was still having problems. Out of sheer desperation I decided to put in a G4 533Mhz processor that I had from an old Digital Audio system. Everything was working GREAT, but the system profiler was showing the processor as a 400Mhz. I did a little research online and found a tutorial on how to change the bus speed via nvedit. The computer has been running for 24 hours and everything seems to be ok. Thank you sooo much for the help!
You're welcome, but I think you should be thanking yourself at this point since you figured it out. :D Anyways, I'm glad I could give some assistance. :D