G4 Superdrive Woes

justinfrench

Registered
Suddenly, today, without rhyme or reason, my G4 Mirror Door 1Ghz decides it won't read CDs or DVDs in it's internal Superdrive (Pioneer DVR-105, original equipment).

Things I have tried thus far:

* repairing permissions (the old favourite)
* zapping the PRAM and NVRAM
* restarting, shutting down, etc (repeatedly)
* looking for a firmware update (can't find one greater than A506)
* looking in system profiler (the drive is recognized, but won't mount any media)

When I open the drive, insert a disc and close the drive, I don't hear the disk spin up at all. I can't see the disc or drive in Disk Utility, blah blah blah.
 

nixgeek

Mac of the SubGenius! :-)
Have you tried single user mode? Apple-S is the key combo to hold down after the bootup chime. Once you're dumped into the command line, follow the directions given to run a disk check on your hard drive. Once it's completed, just "exit" and you should be back on your way to the desktop. Hopefully that should resolve the problem.
 

justinfrench

Registered
ok, so I've run FSCK, and *still* no CD or DVD reading – any more ideas?
 

nixgeek

Mac of the SubGenius! :-)
Have you performed an upgrade from one version of Mac OS X to a newer one recently?

Also try and disconnect and reconnect any cables from the logic board of the Mac to the SuperDrive. I've noticed that at times reseating cables and molex connectors can revive non-working hardware.

If this doesn't work, you might want to try using an app called PatchBurn. This hopefully will bring back your SuperDrive. If not, try testing the system with any spare optical drives you might have (just to rule out the OS as the cause).
 

justinfrench

Registered
I did Panther -> Tiger a few weeks back, but it's been working since then for sure. other than that, I've just applied whatever patches Software Update recommend.

Unplugging/pluggin in did nothing, neither did PatchBurn, and I don't have a spare drive, so I'm guessing it's hardware related, and I'm in the market for a new drive. Any suggestions on a replacement that works with OSX/iTunes/Finder/etc?
 
Top