Garageband And M-audio Firewire 410


I am using Powerbook G4 OSX 10.3.9 for Garageband with M-Audio Firewire 410 interface. After opening the Firewire software followed by opening the Garageband, I get the following constant prompt:

"Timeout or Timer inactive!
Check other applications using Timer or MIDI (code 0)"

The prompt keeps reappearing while Garage band is in the process of opening until the Firewire program disconnects and prevents me from using the interface and thus from strating to record music. Once or twice another prompt - "Warning - Mac OS X MIDI Services not available" - also appeared while in the process of opening Garageband.

I have re-downloaded both the iLife05 and Firewire softwares but to no avail. The above problem persists.

I am just a regular user with limited technical background/understanding of software/hardware issues.

Please help. Thanks.

I've got the same problem with Firewire 410 and Logic Express 7. Only just started using it and completely in the dark!
What driver versions are you guys running? The latest version is v1.5 for Panther and v1.5.3 for Tiger.
Does your 410 show up and operate normally with the rest of the OS/Applications/The M-Audio FW410 control panel?
Have you tried it out with any other Music apps? Try it with the demo version of PT M-Powered from - not that it works with my FW1814...
Have you tried e-mailing M-Audio - their technical support is apparently pretty good.
Have you run Apple's software update?

Sorry about the long list of questions!
Sorry if this is a duplicate post. I tried before and mocosx still says I have posted nothing.

I have a nice new iMac G5. I have a nice new M-Audio Firewire 410. I have the program that came with the 410 working. It reports driver version 1.2.4, but seems to be working. I also can start Garage Band and do not see any errors. Pardon the stupid question, but how do I get the two programs to work together. i.e. How do I record in Garage Band from the 410?