Get Bad Sectors Using Mactheripper


Hello all,
I've looked around on a few forums and found that some have had a similar problem (one is on this site actually), but no real working solutions has been provided, none that I found anyway.
The problem is when I extract the full disc using MacTheRipper 2.6.6, at the end of the rip I get errors that "the DVD had bad sectors, the rip did finish but may not play back."
And indeed I'm unable to play the VIDEO_TS fodler or any of the individual VOB files back, I tried using VLC it loads but there is no picture.
Now this only occurs on a region 1 DVD, I've disabled the DVD player software automatic read and play upon insertion of a DVD movie so that it doesnt ask me to change my region. My drive is currently set to region 4. Is there a way around this? Is this error caused because my drive is set to a different region?
Is there another program that will do this without me having to change my region settings?
I've tried using 'main feature only' and changed a few other settings but still get the same problem, I've cleaned the disc thoroughly in case it was just a dirty surface, the disc has no scratches (I can see).
Any help is greatly appreciated.
But you can watch the entire DVD without problems? Using VLC, of course, since DVD player is set to a different region code.