Getting gnome to run under OSX (X11)

vanguard

Registered
As the title suggests, I'm trying to get gnome running. I *think* I'm pretty close but I've probably made some mistakes along the way.

I d/l X windows and gnome via fink. I modified /usr/X11R6/lib/X11/xinit/xinitrc so that it started gnome-wm instead of twm. That worked.

However, in Linux I had the nice wallpaper, dock (or whatever it's called in gnome) and the start menu, etc. With this, all I have are a few nice looking terminal windows (in gnome/sawfish style).

What am I supposed to do to get gnome "fully" running? Should I change the file back?

Thanks in advance.

BTW, I start X with this command: startx -- -quartz
 

jcpowers21

Registered
I remember I had some trouble getting gnome working. I think all I had to do was edit my .xinitrc file to exec something, but i can't remember what. It was under 10.0.4 and eventually i got it working....sorry for the lack of help. I do remember that it sucked cause i didn't have a lot of the applets and the color wasn't very good, but if you install more things i think you can change it?
 

vanguard

Registered
You had to exec something huh? Could it have been enlightment? Sawfish? gnome-wm?

I wish I could play with my iBook right now but my wife is playing a movie in bed with it. I'm stuck on my work machine (Win2k notebook). I'll write back again soon.
 

vanguard

Registered
I have it working now. I must have put 12 hours into figuring it out and searching for answers. I'm writing back to this board so that we have a searchable archive of what worked for me.

1. I installed fink ( fink.sourceforge.net ) and choose just about everything.
2. I ran startx -- -quartz
3. I saw an ugly twm window manager.
4. I ran "sudo dselect" again to install xfree86-rootless
5. I copied xinitrc to ~/.xinitrc
6. I modified the twm line to read exec gnome-session.
7. I ran startx -- -quartz
8. Observe pretty results.

I you like the full screen window manager you're in good shape. As a matter of fact, you can skip the rootless step.

If you like to have gnome windows mixed in with your OSX windows:

1. Change .xinitrc so that gnome-session is replaced with gnome-wm.
2. Run startx -- -quartz -rootless

Anyway, I wanted to get those steps on this board so that the next guy in my position has an easier time.

I have two remaining issues:

The backspace key doesn't work in my gnome windows. (I get a ~)
I forget the command for a fake three button mouse.

Anybody who wants to do mackind (and me) a good deed can post the answer here.

Thanks in advance.
 

vanguard

Registered
Cool, I hunted down the answers to my questions.

To fix the backspace thing I added this line to me .xinitrc

xmodmap -e "keycode 59 = BackSpace"

To get the three button mouse stuff working I added a parameter to my startx line:

startx -- -quartz -fakebuttons

I hope somebody finds this useful.
 

Red Phoenix

Registered
Another useful thing, if you use sawfish, is to type

mkdir ~/.sawfish

in the Terminal. I don't know if this bug still exists, but originally, Sawfish was unable to save my preferences for it, since it did not create that folder. Once it was created, suddenly all my preferences stuck.
 

chrisp

Registered
vanguard: There's no real need to use just gnome-wm instead of gnome-session if you're running rootless. You can close any GNOME program you don't like and let gnome-session remember it. (It usually asks if you want to save the session on logout; you can also save the session explicitly through the GNOME menu on the panel.) The panel can be configured to sit in a corner instead of occupying a whole screen edge.

The emulate three buttons option can be activated persistently in the Preferences dialog of XDarwin. Then you can start it just by double-clicking the icon, no need to use startx.

I'd also advise you to use xfree86-rootless instead of xfree86-server even if you run full-screen. There are many other improvements than just rootless mode. While it was built from a development snapshot, it has been tested by a large user base by now and can be considered reasonably stable.


Red Phoenix: The sawfish mkdir problem is fixed in version 0.14-5 of the librep package, shipped with Fink 0.3.0. (librep implements the Lisp dialect in which a large part of sawfish is written.)

-chrisp
 

knussear

Registered
My gnome works fine, but I cant get my terminal to run. The error message is below. I would appreciate any help.



[user1:~] knussear% gnome-terminal
using device Built-in audio controller for output:
with sample rate 44100.000000, 2 channels and 32-bit sample
using device Built-in audio controller for input:
with sample rate 44100.000000, 2 channels and 32-bit sample
Living environment not ok
Error: unable to fork: Broken pipe
 

chrisp

Registered
Read the FAQ: http://fink.sourceforge.net/faq/packages.php#gnome-terminal

Q: Why won't gnome-terminal start up?

A: There is a bug in Mac OS X 10.0.x that keeps gnome-terminal from working. The actual bug (file descriptior passing doesn't work) is masked by another issue (ununual stack size limit), which was left as is to produce an error message when gnome-terminal is started (thus preventing even more confusion). It is expected that this will be fixed in Mac OS X 10.1.
The Fink package will be fixed once we're ready to drop 10.0.x support...

-chrisp
 

knussear

Registered
Cool,

I've been going nuts trying to find something wrong in the configuration


I look forward to the update

KEn
 

Red Phoenix

Registered
Once upon a time, chrisp posted
The sawfish mkdir problem is fixed in version 0.14-5 of the librep package, shipped with Fink 0.3.0. (librep implements the Lisp dialect in which a large part of sawfish is written.)
Great! As soon as I tried it I loved everything about Sawfish except for this bug, but I just couldn't get myself use it (until I heard about the work around). There are a lot of nice, more mature, touches in Fink lately. I just noticed yesterday that fink list doesn't sudo itself anymore, meaning I can finally have a cron job that e-mails that list to me every morning (or something).
 

Da_iMac_Daddy

Not-so-Neo-DumbA$$
what do I need to download to get Gnome running? I already have Sawfish installed and working there are just like two million things to download for gnome on fink. So if anyone feels the need to answer me I'd be very grateful.
 
Top