gNAT - software base station OK but no DNS ?

mmurray

Registered
I have a G4 tower connected to ethernet with an internal airport card
and a G4 TiBook with airport card. I have been experimenting with gNAT
the apple tool for sharing IP's that can be used to set up a sort
of software base station.

I can get the TiBook to talk to the internet by setting up gNAT as per the
enclosed instructions on the tower but I can't get any DNS to work so everything has
to be done by IP number. Does anyone have any hints on how
to do this ? On the TiBook network control panel I have tried
no entry in DNS, the IP of the virtual router 10.0.1.1 and the
IP of the real DNS that is on the network the tower is connected to.

Thanks - Michael
 

jwblase

Registered
I think it's a problem with gNAT and 10.1. I'm under similar situations, but gNAT was working before I updated. Haven't received a reply from the author of the program yet, but I think gNAT has to be fixed.

Has anyone else been having problems with NAT routing on X.1? I need this router in order to work the other 2 computers in my apartment.
 

Kinniken

Registered
Dont tell me there is no solution but to wait for a fix!
I have been struggling with setting up a shared connection over firewire (internal) and ethernet (external), using IPNetShare for routing. After a lot of toying around, it works... bar the DNS. Which basicaly mean it's useless.
Grrrrrrrrrrrrrrrrrrrrrrrrrrr :mad:
 

.dev.lqd

Angry Member
What you want to do is setup a caching DNS server.

There -should- be instructions somewhere on the web... basically... the server will talk to your ISP's nameserver, and all the client machines on your network will talk to your server for IP resolution (DNS addressing/hostname lookup/etc. etc.).

The other solution would be to assign the DNS servers that your server looks at to all your client machines... this is what I do in my home because I haven't had time to setup DNS.
 

Kinniken

Registered
It's not working though...

Oh, and also tried getting my client comp to connect to a third-party DNS server, still does not work. The third-party server does work with the comp doing the routing. Very strange.
 

SCrossman

MacTech
Try using nslookup in terminal. You should see something like this :
[localhost:~] mactech% nslookup
Default Server: alpha.buf.adelphia.net
Address: 24.48.33.2

That is the DNS server assigned by my router using DHCP. Let's start with that and see what is returned.
 
Top