Gravis Gamepad Pro

Jadey

sosumi
My USB Gravis Gamepad Pro doesn't work in 10.0.4 (or before). Resolved in X.1? Whatya think? I play THPS2 in 9 right now because this gamepad doesn't work in X. I'd rather not reboot :cool:
 

Trip

Registered
Out of all the things they've resolved in 10.1 I'm pretty sure your gamepad was not included.
I play THPS 2 all the time just by using my keyboard...and I must say: I coulda never put in so many tricks within one combo on any type of gamepad.

So you have two real choices: sell your current gamepad for one that's compatible with OS 10, or just use your keyboard.
 

iEvan

Registered
Has anyone confirmed this under 10.1 yet? I'm anxious if there is any hope for gampads on the Mac...especially the iShock 2!
 

HyperLiteG4

Registered
I'm in the same boat as well. I have a Gravis Gamepad and want to play Tony Hawk on my TiBook, but it is impossible to play with it since there is no number pad to use. I will be lined up 10am saturday morning for 10.1 and we'll see if it works. If not, I guess we just have to bug Gravis about getting some drivers out. I know I have seen on VersionTracker.com that other drivers for other gaming devices are coming out, so who knows about this.
 

Jadey

sosumi
Keyboard playing not an option here. I get sudden, nasty carpal tunnel after a couple of minutes. I can play for hours with my gamepad, or on my ps2 or n64 with their controllers.
 

AdmiralAK

Simply Daemonic
dang!
The last game I played (with a game pad) on my mac was Castlecania:SYmphony of the night :p....

Anyone know if another castlevania is coming out ?
I am a big fan of the series:rolleyes:

Also grand turismo he he he I got a playstation emulator but never got any games except Fifa 98, GT and Castlevania :p


Admiral
 

Jadey

sosumi
ohmygawd this thing is difficult to configure. Have to key map the different buttons to the gamepad - which is normal, but you gotta pick your buttons from a drop down menu that is like this:

Button #1
Button #2
Button #3 and so on..

which button is button #1? Doesn't say. I've done about a dozen restarts of THPS2 to try and get it working. I've got about 1/3 of it mapped. For anyone going to use the GamePad Companion.. just know it's a difficult road, but worth the trip. :cool: Also: doing this with my USB Gravis GamePad Pro - it automatically detected my device correctly, immediately.
 

Soapvox

Want some of my Kool-aid?
you plug in the device, then click the button in the panel to map, click the button on the pad and viola, set the key to map, I set mine up in about 5 minutes
 

Jadey

sosumi
Originally posted by Soapvox
you plug in the device, then click the button in the panel to map, click the button on the pad and viola, set the key to map, I set mine up in about 5 minutes
Works differently here. I can't just click a button in the panel to map - it's all in a drop down menu and the menu items are labelled generically. There's no way to tell from within the application which menu selection cooresponds to the button on the gamepad.
 

Soapvox

Want some of my Kool-aid?
Click the highleted button in my screen shot first, then hit the key on your pad, then click map key button, then the button that you are mapping
 

Attachments

Jadey

sosumi
This is the way I tried originally. I gave it another shot, but it still doesn't work as you've described. However, you are using a different game controller than I am.
 
Top