Hard disk - how to proceed? Part 2


The scenario is a failed hard disk containing some photo files that I want to save if at all possible. The advice below (thanks guys!) was to try DiskWarrior or to start up the iMac as a Firewire drive whilst linked to another Mac and copy over the files.

I bought DiskWarrior and ran it, it returned the following message: "DW has successfully built a new directory. The new directory cannot replace the original directory due to a Mac OS services failure - try rebuilding again". I've done it three times with the same result.

I tried the other suggestion. I booted the iMac holding down the "T" key and I got a Firewire logo on the screen - so far so good I assume. However on starting up the second Mac I got a message saying "You have inserted a disk containing no volumes that Mac OSX can read"

Clearly there are some serious problems here. Any other suggestions? I tried starting in "single user" mode and typing the command "fsck_hfs -fyr/dev/rdiskOs9" as mentioned in another thread but just got the message "no such file or directory" As an experiment I tried the same command but ending in "Os10" and got an "illegal option" message. I've no idea what any of that actually means by the way!

If I were to attempt to re-install OSX, would I lose any chance of recovering the photos? I'm thinking that a re-install might then allow DiskWarrior to complete the job. Any suggestions gratefully received!
Hey - thinking that since you are able to access the HD thru DiskWarrior you might be able to do so with other utilities. DiskWarrior is a brilliant program, but it's also only a disk recovery and defrag application. Your problem might be a OS X permissions gone wrong or something. I'm assuming that when you say "failed hard disk" you mean that when you try to boot on to that drive the boot ends with the access denied symbol (circle with a line thru it). Ususally, when I've had such a problem by booting the install disks and running disk utilities fixes the problem -- and if it doesn't, I assume the worst (but it's never come to that).

I have no idea whether this would work, but you could try a program like Cocktail - which not only cleans the system directories but repairs the disk permissions too.
(...My logic is running along the lines of - If you can't repair the disk permissions thru disk utility because it will not allow you to access the disk, since you can access the disk using DiskWarrior; you _might_ be able to do so using Cocktail...)
Cocktail is a free download from here:
Like I said, I have no idea whether this would work - but maybe worth a try...
Thanks for the suggestion but doesn't seem to have worked - ironically Disk Utility on the attached (live) Mac can see the problem Mac as a Firewire drive but can't do anything about it, whereas Cocktail (which might be able to do something) doesn't see it! I might add that the hardware diagnostic in DiskWarrior says that the problem hard drive seems to check out ok, so I don't think its a mechanical problem.
Cocktail will do nothing. This has got nothing to do with permissions, and if Disc Warrior fails, there is no chance that Cocktail/Onyx or whatever permission repair tool you're going to use will work.

When you've loaded up the good Mac and can see the problem Mac as a firewire drive, what error do you get when you try to access it? What does Finder say? You might want to try the Terminal and see if you can "cd" into the drive.

Failing all that, you might want to try Data Rescue. A bit pricey, but if you really want your photos and nothing else works, this may be worth a shot.
Thanks for the suggestion about Data Rescue, I might try that. $89 isn't so bad, DiskWarrior cost me £78 yesterday.
The only way I can see the problem Mac as a Firewire drive is in Disk Utility, which doesn't give me an option to do anything. I can't see it using the finder, and can't see a way of trying to access it. I don't know how to use Terminal.
OK. If you can't see it in Finder and only on the Disk Utility, things are bad. I would suggest getting Data Rescue and seeing what that program can salvage off that hard drive.

Personally though, I'd wait a bit before splurging out the money. There could be someone on these forums who may know a solution that doesn't cost as much.
Cheers Viro, appreciate your help. What I'm doing at the moment is using Data Rescue's Demo version to scan the damaged hard disk - they have a demo that lets you do the scan but only allows you to recover one file, a very good and sensible way of letting you see if their utility is going to work in your circumstances before you pay out - top marks to them. It is taking a very long time though, its been running for 6 hours now and seems to be about half way through. I'll leave it running overnight and see what the morning brings. Thanks again for the advice
It worked! The scan was still running when I left for work (over 12 hours after kicking it off) but when I got home it had successfully identified the data files on the damaged disk. The test recovery worked fine, so I paid the $89 for the activation key and successfully recovered the lot. As the photos included some really good ones of my grandmother (now deceased) this is a major relief! Needless to say I've learned a hard lesson and they're now backed up! I'll see if I can revive the problem drive this weekend. Sincere thanks to all who offered advice.
my firewire HD crapped out this past week...
DW starts its thing, but loops before it can finish...

This Data Rescue looks promising... glad to see it's working for you. Is it strictly download or will they send you a boot CD? (unless thats not applicable)...

Will bookmark the link and possibly get into this later in the week when i have the time... it seems like you had your hands full (or at least no access to your mac) for a long time...
In fact, it's the only recovery application that I've found worth keeping. If you're really serious about the files you want to rescue, you should ALWAYS try DataRescue FIRST. Sorry for shouting, but this is rather important.

Data Rescue doesn't do anything to the drive you're rescuing the files from. It doesn't try to rebuild directories or anything, it simply reads what it can find, and allows you to copy the files to another volume.

This is the right thing to do first. If it fails, you're screwed anyway, because no other utility can rescue something that can't be read from the device. If it works, you can make a backup, and then go ahead to try to rebuild directories with other utilities. If that fails, you still have the backup.
I have the same problemon an iMac flat panel G4. I would like to salvage some photos and personal files. However, I can't even boot up with DiskWarrior. I get a blue screen and a spinning "wheel" - it's been about 2 hours now. Can I boot from DataRescue? I've downloaded the demo on my other Imac(G5). How can I use it on my G4.
I could really use som help on this one. This has never happened to me before. I've been using Apples since Apple IIe's.