HD keeps spin up and down after deep sleep in OS X

Leonis

Registered
Everytime when my G4 is running OSX and after wake from deep sleep the HD keeps spining up and down every five minutes. I am sure I set the HD sleep to NEVER in the control panel

I do also turn the machine in deep sleep when running OS 9 but I don't see the HD spin up and down problem.

Is it a bug in the energy saving control panel in OS X??
 

omegaroot

Apprentice Codemonkey
Im suffering the same issue and I am browsing the web, running AIM, etc... and can hear it spinning up and down, I checked the energy saver pane several times and its set to never for both system and drive.

I even tried running X optimize cause I knew it would be making disk calls and such to try to combat this but it still did it...?

This is the first time I have noticed it and have been running 10.1 for 2-3 weeks now.

At leaste you know your not alone Leonis.
 

Makosuke

Guy Who Loves X
This is at least the third thread here talking about this same problem. It seems to be a simple bug in Energy saver that shows up after deep sleep--the hard drive (or one of them if you have more) nodds off (spins down then immediately back up) every few minutes.

I'm still not quite sure if this is a reliable work around, but setting Energy Saver to never sleep, shutting downd and restarting (it definitely won't do anything if you don't restart), then telling the system to go to sleep manually doesn't seem to precipitate the problem. It's a little hard for me to be sure, since I usually turn my system off instead of sleeping, but after setting sleep to never I haven't specifically noticed either of my drives nodding off.

Can anybody confirm that this does or doesn't work?
 

severus

Registered
Makosuke - no, it doesn't work. After restarting, the problem goes away, but as soon as I put my system to sleep manually and wake it up, the quick spin down problem resurfaces. It's very annoying.

System info: G4 450 DP, 640 MB RAM, 10.1, firmware 4.2.8, all updates installed, stock 30 GB IBM drive.
 

Makosuke

Guy Who Loves X
Thanks for the confirmation; I did some more testing myself, and it turns out that I just hadn't checked thoroughly enough--it is putting the system to sleep that starts the spin-down problems, and they occurr no matter what you do with Energy Saver.
 

omegaroot

Apprentice Codemonkey
I found a work around. just leave distributed.net client running all the time :D
well there is some truth to that... havent heard the HD spin up or down since, but the amchine hasn't gone ot sleep either... oh well, hopefully apple will address this issue.

no im not getting any kick backs from distributed!!!
 
Top