Help! Can't install OS9 (Classic) from OSX

RomanticWarrior

Registered
Hi,

I just installed OSX and I also used Disk Utility to initialize the whole HD and pade 2 partitions. One for OSX and one for OS9. I can run OSX just fine; in fact I am in it right now. The problem is I don't know how to install OS9.1 so I can use Classic. I tried starting up (pressing c while starting up) with the OS9.1 CD but it loads OSX on HD instead of the 9.1 on the CD.

I appreciate any help!

Thanks in advance.
 

RomanticWarrior

Registered
I just tried, still will load OSX.
I even pressed C all the time...
Argh, what's going on!?
 

endian

Dis Member
Try it again, this time *don't* press C. If that doesn't work, hold down option & select the CD from the Open Firmware boot screen
 

RomanticWarrior

Registered
Thanks, I actually tried without pressing C with boot disk selected in the prefs, but havent tried pressing opt and restarting. I'll go try right now ;)
 

RomanticWarrior

Registered
I tried pressing opt while booting up. Screen came up with an "rotation" icon, "arrow" icon, and the drive that's selected. I pressed the rotation icon several times but it only showed the hard disk with OSX on it. I use a PowerBook G4 with DVD-ROM drive, if that matters.
Any more suggestions?
 

endian

Dis Member
nope, sorry. I'm stupmped.. It sounds like something specific to your hardware.. try searching on Apples site for a relevant TIL article, or at macfixit.com or macintouch.com
 

endian

Dis Member
oh wait, didn't a firmware update just come out for the PB G4? see if the release notes for that say anything about improving DVD-ROM support. Make SURE you want to install it though, since apparently some people have had it disable their 3rd party RAM, and there's no downgrading once it's installed.
 

RomanticWarrior

Registered
I checked the firmware update and it says it needs to run from 9.1. I'm stuck in OSX so I have no way to run it.
Although it does mention about FireWire boot mode improvements or something.

I posted the same problem on macfixit but so far no one has replied to me with a helpful suggestion.
I tried zapping the pram then pressing the C to boot up from the CD, but that didn't work. I even tried option startup. No avail.

Argh.. theres gotta be a way to install OS9 from OSX without Classic.
 

kilowatt

mach-o mach-o man
Just an idea.... You could try making a floppy boot disk. (if you have an on-board floppy controler - don't think it'll work over usb). And, if you really want to try something, try zaping your pram (thats where startup settings are, like booting from the harddrive or cdrom). I think you hold down opt-apple-p-r on startup, and that will do it - check a manual first. Then booting from a cd should go fine (with the c key held down, of course). Good luck with all this.
 

binHex

Member
You can't install 9.1 from the CD shipped with OS X. This is the case with PB G4 and all AGP machines beqouse the MacOS ROM file is to old on the CD. I've encountered the same problem. If you can get your hands on an older G4, G3 etc. then a solotuion is to make a system folder from the X shipped CD that allow you to drag-install.

1) Install 9.1 from the original PB G4 CD.

2) Drag the X Systems from the "drag-install" folder

3) In the just dragged system folder.
Replace the MacOS ROM file (found in the system root folder) with the MacOS ROM file from the PB 4 original system folder.

4) install MacOS X

5) Through the original PB 4 system in the trash

6) Start Classic

I Supose there is other ways to deal with this but this one worked for me.
 

binHex

Member
I was succesfully able to install 9.1 using the CD that came with my powerbook, not OSX.

--------

That's good, but be aware that for AGP G4's and PB G4 bought in foreign countries with languages that X don't yet support the install through the original CD does'nt do the trick.
 

ttimes

Registered
Its like this:
Of my two drives, Drive 1 is OS 9.1 and Drive 2 is/was OS X 4K78. Currently, I can only boot from the OS X install CD. Holding down option or 'C' does nothing but cause the computer to hang at a grey screen with a single cursor. Oddly, Os 9.1 is accessable and works from within OS X. However, if I select to boot from the OS 9.1 drive from the OS X system Panel Startup Disk, it hangs as before. The ONLY way to acces any drive is to reinstall OS X over the existing OS X partition. Nothing else works. Once installed, I can reliably boot from the OS X drive but nothing else. I have tried using my original B/W install disk as well as a functional OS 9.0 installer.
Any ideas?
 
Top