Help! Can't recognize hard drive after OSX/9.1 install

clason

Registered
So here's the deal:

I had OS 9.0, and installed OSX public beta when it came out (on the same disk as 9.0). When the new OSX came out, I installed that as well, over the top of OSX beta. I've learned since that this is "very bad". I then upgraded my classic environs from OS9 to OS9.1. Things were working fine, and I was running in OS9.1 for a while for various reasons.

Then I restarted my computer while holding the shift key down, and now neither OS9.1 nor OSX recognizes my hard drive, and both suggest that I initialize it! Help!

I've tried Disk Doctor, and it tells me that it finds problems with my hard disk but cannot resolve them. I'm in so much trouble... anybody have any ideas?
 

sfish

Fark Lover
I ran into a similar situation with Public Beta a while back. Maybe someone will have a better solution, but if no one else writes back, consider this:

1) Boot using the CD that came with your system.

2) Run the program "Drive Setup."

3) In the program's window, look under "List of Drives" for a drive (probably the second or third one listed) that is not mounted.

4) Click once to select this unmounted drive from the list of available drives.

5) Select "Mount Drive" from the "Functions" menu. After a few seconds, the missing drive should appear on your desktop.

6) Quit Drive Setup.

7) Now you have access to the problematic drive. Back up all your critical files! You do have some kind of storage for doing this, right? :)

What you do next is your call. You can try to reinstall the OS on top of what's there. You also can wipe the hard drive after backing things up and reinstall everything.

Although many people would probably disagree with me, after using MacOS in various forms over the last 17 years, I tend to be a scorched-drive theorist when it comes to critical repair: If the problem is big enough to make me sweat profusely, it's probably going to haunt you later if you don't start from ground zero. Wiping the drive like this forces me to backup if I haven't done it in a while, it assures me that later problems can't be atributed to "that time last month when I should have just wiped the hard drive," and since it takes a little time if forces me to become Zen about the entire experience.

Best of luck!!! Let us know what you decide to do.
 

clason

Registered
Thanks very much for the advice of using Drive Setup. Unfortunately, no dice.

When I use drive setup, I can see the drive, but when I try to mount it as suggested, nothing happens. : (

Any other advice? My general next course of action would be to purchase one of the many disk tools on the market (i.e. Norton, etc.), and if that doesn't work, haul it in to my authorized Apple re-seller to have them take a look.

I do have backup media in the form of a CD-RW, but I've also got a tremendous amount of data on the computer. My long term plan was to get an external hard drive to do backups, but as of now, I have none.

If and when I make it out of all this, I probably will pursue the "scorched hard drive" approach and re-format the durn thing.

Any other advice would be greatly appreciated at this point.

Thanks,

Andy
 

sfish

Fark Lover
What version of Drive Setup did you use?

If it was for a version of Mac OS before 9.1, it might be that. I probably should have suggested you boot from the 9.1 disk that came with Mac OS X.

Let me know if that helped. If not, I'll wrack my brain for some other solutions.

How about anyone else?
 
Top