Help Me Print While Using Yosemite


I have a Samsung ML-1740 B/W Laser printer that I have used for the longest time with my mac computers. It is still a good printer and works fine.

I recently upgraded my 15" Macbook Pro from 10.7 to 10.10 and have lost the ability to print. Watching the print que, I can sent the document being processed and sent but nothing comes out of the printer.

I can still print to my Epson inkjet thru the 10.10 but not Samsung.

Samsung will print for a 13 Macbook Pro on 10.9 and a Mac Mini on 10.6

both the Espon inkjet and Samsung are usb through the Airport Base Station

tried looking @ cups but that is a bit above my comprehension level.

would prefer not to get new laser printer since this is working for the others

any ideas?
After you upgraded, did you go to System Preferences>Printers and make sure all your printers were listed and connected?
Did you check for printer driver updates - either through the App store or Apple’s download page?
I have deleted and re-found both printers. The inkjet is working without issue. Samsung does not "really" support the 1740 printer and hasn't for awhile, but we have always found a driver for it one way or another. we followed the same process to get a driver for the laptop running 10.9 (because it worked) on the 10.10 and yet it doesn't work.

system sees the printer, printer que shows that job is processing and then it disappears - it now says "filter failed" after the document does not print.
Have you tried unplugging the usb, then plugging it back in? Have you tried plugging the Samsung direct to your computer? Some printers will not work unless it connects wired to the computer first.
I plugged the samsung printer directly into the laptop and still the same results - filter failed error message
Then you can’t use that printer on that machine. 10.10 doesn’t like it.
found this nugget on mac forums - ran the commands to open the files, copied files into the other file and then tried a test page - Error message said "would you like to repair permissions?" clicked yes and the samsung printed

I had a similar problem with my HP PSC750 supplied with a levelone wlan print server.
The problem ist simply the sandboxing of yosemite. The whole foomatic-software including hpijs and gostscript is normally installed in /usr/local/bin, where cups has no access in yosemite. I solved the problem by copying the whole content of /usr/local/bin into /usr/libexec/cups/filter. In this directory you must remove the link to foomatic-rip in /usr/local/bin before.


cd /usr/libexec/cups/filter
sudo rm foomatic-rip

cd /usr/local/bin
sudo cp * /usr/libexec/cups/filter

(if you have installed a lot of other software in /usr/local/bin, it is better not to copy all files, of course)