Help me ressurect my iBook

pedlja

Registered
I have an iBook with OSX 10.3. The last few times I've put it to sleep it's had a hard time waking up...sometimes the pointer/mouse would freeze and I'd have to restart. Normally this wasn't a big deal.

One day last week I had to restart and on startup, I got the dreaded blinking question mark. I ran disk first aid and it found nothing wrong. When I tried to run the disk utility from the OSX install screen, it wasn't seeing my hard drive at all. I think I've tired every combination of keys on startup and nothing was working.

Somehow on my final resart (without holding keys down) it started up and was working. I used it for the entire day and night and then my wife put it back to sleep and there were several clicks before it passed out. (not from the CD drawer) Now I can't get past the blinking question mark again.

Any thoughts? Is there hope?
 

AndyUK

Registered
Hi.
First thoughts are faulty HD, but there are a few ways you can check.

First one is hold down the 'alt' key when you hear the startup chime, it should boot you into a blue screen and you will have arrows on either side of the screen along the bottom.
Give it a minute or two and it will show you any available startup discs in the centre of the screen.
If there is an icon of an HD with an X next to it then that will be your OS X volume on your HD, click it once and click the arrow on the right to boot into that volume. (You may also have an OS 9 volume there, try that too)

If nothing appears there then run the AHT (Apple Hardware Test) which will have came on one of your original iBook CDs (should have it written on disc).
Boot into that disc and i like to run the extended test - if this finds a fault with your HD it will give you an error code and if your machine is still under warranty, call apple and they will repair it under warranty.

You could also purchase Disk Warrior, this is a more advanced check for your HDs, but this means forking out for the software and possibly the repair of the HD also, but there is a slim chance it may be able to fix the issue preventing the need for repair.
 

pedlja

Registered
Thanks.

I did the ALT key thing and got two buttons the left button had a circle-like arrow on it and the right button had a right arrow on it. There was nothing else on the screen. Clicking each arrow did nothing. I think I waited long enough for anything to come up, but I'll try it again to be sure.

Also ran the Apple hardware (extended) test...all results came back normal.
 
Top