HELP! Random iMac Aluminum 20" Crashes on boot

zynizen

Registered
Last night I was minding my own business on the internet, and checking on some news articles. I always leave the iMac on at nights, for quick access in the morning before I go to work.

This morning I wake up and the iMac is off, so I turn it on and BAM! It won't even boot. It crashes every time. It's funny this happened now, because my brother's exact same iMac randomly does this all the time. It's now at a point where the only thing I can do is hold SHIFT and boot into safe mode.

WHAT do I do? Why would this happen all of a sudden? I didn't do anything, the computer just randomly crashed?! that's horrible! I'd expect it from a windows box, but 10.5.4? I'm not running any fancy software on here, just Office 2008, Photoshop CS3, Acrobat, and Illustrator.

Please, I ask for all your help!
THanks

PS: here is the crash log:
-----------------------------------------------------------------------------
panic(cpu 0 caller 0x001694C6): "vm_map_unwire: entry is unwired"@/SourceCache/xnu/xnu-1228.5.20/osfmk/vm/vm_map.c:4110
Backtrace, Format - Frame : Return Address (4 potential args on stack)
0x342a7df8 : 0x12b0fa (0x4592a4 0x342a7e2c 0x133243 0x0)
0x342a7e48 : 0x1694c6 (0x45c20c 0x3bae3000 0x0 0x342a7f0c)
0x342a7f28 : 0x5be328 (0x3baf3000 0x0 0x0 0x0)
0x342a7fc8 : 0x19ebdc (0x0 0x0 0x1a20b5 0x3ed6128)
Backtrace terminated-invalid frame pointer 0
Kernel loadable modules in backtrace (with dependencies):
com.apple.BootCache(30)@0x5bc000->0x5c0fff

BSD process name corresponding to current thread: kernel_task

Mac OS version:
9E17

Kernel version:
Darwin Kernel Version 9.4.0: Mon Jun 9 19:30:53 PDT 2008; root:xnu-1228.5.20~1/RELEASE_I386
System model name: iMac7,1 (Mac-F4238CC8)
-----------------------------------------------------------------------------
 

bbloke

Registered
Sorry to hear this, zynizen.

A few ideas off the top of my head:

1) Have you installed or touched any of the RAM recently?

2) Have you installed any software recently?

3) Have you tried booting your Mac with no peripherals attached?

4) Have you tried fsck in single user mode?

5) Were you using Time Machine (i.e. a last resort might be to go back to an earlier state)?

6) Does your brother live locally? If so, do you both use surge protectors and/or have there been any electrical storms or other power-related problems (this is a bit of a less likely scenario, but I thought I'd raise it)?
 

zynizen

Registered
1) NO

2) NO

3) Yes, I never have any peripherals attached, unless I'm grabbing something from my external hdd occasionally after leopard is booted.

4) Yes, it says the filesystem appears to be OK, I even followed apple's specific instructions after safe boot, reboot normally, if its ok, great, if not, errors.. continue fsck, still no luck.

5) unfortunately I don't have a hard drive with time machine backup on this iMac. Because I just use it for surfing and occasionally downloading stuff.

6) Yes he does, and now that you mention it, the power did go out, and I have a Belkin Surge Protector. (not battery backup). The problem just started happening, so, maybe its related to a power surge? that still doesn't explain why everything works fine in safe mode!!

thanks
 

bbloke

Registered
Hmm, curiouser and curiouser!

When you referred to the power going out, have the problems for you and your brother started since a power cut/brown out/power surge? If there had been a power spike, I'd be a little concerned about potential hardware damage, and would want to rule that out through running diagnostic software. If things have started since your Macs had been forced to shut down due to a power cut one night, I wonder if it could be a case of corruption of system data.

Out of interest:

http://support.apple.com/kb/HT1564
Apple said:
Starting up into Safe Mode does three things to simplify the startup and operation of your computer:

  • It forces a directory check of the startup volume.
  • It loads only required kernel extensions (some of the items in /System/Library/Extensions).
  • In Mac OS X 10.3.9 or earlier, it runs only Apple-installed startup items (some of the items in /Library/StartupItems and /System/Library/StartupItems - and different than login items).
  • Mac OS X 10.4 Tiger only: It disables all fonts other than those in /System/Library/Fonts .
  • Mac OS X 10.4 Tiger only: It moves to the Trash all font caches normally stored in /Library/Caches/com.apple.ATS/(uid)/ , where (uid) is a user ID number such as 501.
  • Mac OS X 10.4 Tiger only: It disables all startup items and any Login Items.
Taken together, these changes can work around issues caused by software or directory damage on the startup volume.

Some features don't work in Safe Mode

Safe Mode can be useful for troubleshooting. However, certain Mac OS X features do not work when you are started up in Safe Mode. For example, you can't use DVD Player, capture video in iMovie, use an AirPort card, use audio input or output devices, or use an internal or external USB modem.

Other ideas:

1) Does your Mac boot OK from an OS X (Installer) DVD? If both Safe Mode and booting from an optical disk are consistently fine, I'd begin to suspect it is corruption of data on your hard disk (i.e. a software issue, not hardware).

2) Did you receive a diagnostics CD with your Mac, which you could boot from and run? This will clarify whether or not there is anything obviously wrong with your hardware.
 

zynizen

Registered
As a last resort... I backed up all my stuff just in case from Safe Mode.

Then this is what I did to fix it:

From safe mode, I rebooted from the leopard dvd, and re-installed it, with an "Archive and Install".

After installing/booting up, I had to do many updates, including firmware, but it runs like a charm. Looks like it was a corrupt system folder.

Hope this helps for others. Nothing has been deleted, all my documents,settings, etc were still intact when chosing "keep existing user account" on above installation.

Cheers
 
Top