Help with Mail - SMTP problems



Since I installed OS X, I've added several email accounts and inbox rules/filters, and everything has worked fine. I've fetched over 2500 emails with it so far.

However, I have not been able to send one email with it!
I get the same error every time I try to send an email:

"This message couldn't be delivered, because the SMTP host did not recognize any of the recipients".

I've checked the adress many times over, and there's nothing wrong with it. I've also checked the SMTP in the Preferences, and it is correct (it is a Swedish SMTP server called I can send emails to the same recipients using the same SMTP server with Outlook Express on my old 5400.

I know the problem must be in OS X, but I have no clue of what it can be. I'm grateful for any/all help I can get.


I had this same problem too until I discovered that I had my incoming and outgoing email machines swapped ( is my ISP's incoming mail server and is my outgoing) and that my ISP's POP server didn't support SMTP. What made it difficult to detect is that I could POP my mail from but I couldn't send it through because that machine lacked SMTP support.

Check to make sure you have both incoming and outgoing mail servers configured correctly, they are on seperate panels in the preferences section of and it's real easy to miss configuring the outgoing mail server if you don't scroll down to that section.
No, I have the right SMTP, and in the right field too.
I've probably checked a hundred times by now :)
This is weird...
Are there any other emailclients available for OS X so far? I see that Outlook Express is OS 9 only still.

Ok, it works now.
My fault completely :eek:
Under the "User" secition in "Mail Preferences", I had written my login name in the second field (the one called "Your user name") instead of the email I wanted to use as the sender-email.
In Outlook, I just choose which email I wanted to send from in each message I wrote (with one as default, of course). What if I want to send email from a different adress in "Mail"? Will I have to go to the Preferences and change that field every time then?