HFS Hard drives missing after revert back to OS 9

Ok-

So now I am in a majorrrr bind. I reverted back to OS 9, and booted up fine, etc. Two of my secondary drives (one the second IDE channel as the master, and one on a PCI Adaptec SCSI card) do not show up. I can view them in Disk Setup, First Aid, and Hard Disk Toolkit, but I cannot them to mount at all! I am trying everything here and I desperate to get the data on the secondary IDE drive because it contains all my clients phone #s and databases. If someone could help me please either email me or leave a reply to this thread.
My machine specs are as follows:
G4/400 PCI Graphics not AGP
512 megs RAM
1 - 10 gig internal IDE drive as master on first IDE channel
1 - 40 gig internal IDE (Maxtor) drive as master on second IDE channel
1 - 3 gig internal SCSI drive on Adapect 2940 UltraWide SCSI card.
If any other specs are necessary to solve this problem, let me know. Thanks


--Josh
josh@digiwave.com
 
I forgot to add that the interal 10 gig (on which my OSX and OS9 reside) is formatted for HFS+

The other two drives (40 gig, 3 gig SCSI) are both formatted for HFS standard, not +. I think this might be part of the problem. I need to access these two HFS drives.
 

BeigeG3Master

Registered
Please post your total system specs in your signiture for better service for any question you may have for now and the future. it also helps for other board members to understand your system better. See mine for example. you can set it in the profile up at top of forum
 

ChrisC

Registered
I had the same problem. The internal UW SCSI partitions other than the one with my system folder was on became invisible in OS9. They were formatted as HFS. I did have another IDE drive (where OSX lives) partitioned as HFS+. Those seemed to be fine. What I noticed was that I could see the HFS partitions under OSX, so while in X I copied their contents to the visible HFS+ formatted drive (all of the partitons including my OS9 sys folder) then logged back into OS9, reformatted the SCSI hd as HFS+ and copied everything back to the SCSI partions. It caused me a real panic when I thought I had lost my drives, but there are still there, no data is gon they just seem to be invisible to OS9.

ChrisC
 

dsteck

Registered
I had the same problem with an hfs partition disappearing. I have os 9 and os X installed on separate hfs+ partitions, with another hfs partition for communicating with LinuxPPC. After installing OS X, booting into it, then booting back into 9, the hfs disk was no longer visible. I ran diskwarrior on it, which among other things made it automount again, so it is now visible under os 9 & X. Other disk utilities may work too.
 

ByteMonster

Registered
I had the same problem...it turned out to be the custom icons I used were screwed up. I ran DiskWarrior and I was fine.

Good luck!
 

rhino

Registered
I had the exact same problem on my box.
G3 350 (overclocked to 450)
512 meg of ram
Toshiba DVD drive
2 Western digital 20 gig drives

Once I got back to OS 9 I ran DiskWarrior and my hidden volume mounted and is now accessable. This happened a second time and Tech Tool also worked.
 

skueppers

Registered
After installing OS X, I found that my HFS partitions didn't appear under OS 9, too. I found it interesting that they didn't mount even when I booted from an OS 9 CD, but they showed up in the Apple System Profiler and in any HD utility I ran.

I also found it interesting that four of the affected HFS partitions had been formatted with a third-party utility (APS PowerTools), while one had been formatted with the Apple drive formatting utility.

After fiddling around with it for a while, I ran Norton Utilities 5 on the affected partitions. Norton Utilities reported that the root directory was invisible, and asked if I wanted to fix the problem.

I can now use the partitions again in OS 9; I have not yet tried booting in OS X again to see if they still mount there.

(There was one partition that Norton Utilities got confused on and never offered to fix, although the drive report says that the problem was encountered and fixed. This partition still doesn't work in OS 9, so I'll probably have to reformat it.)

-Sonja
 

Matt Shannon

Registered
G3:350
256MB
OS9 boot disk with separate OSX boot disk

I've got a 6GB VST Firewire drive that has disappeared also. I can't get techtool 3 to remount it and nothing else will work. I can see it in OSX, but not OS9. Sherlock (in 9) tells me it is there and lets me search on it, but won't let me access anything on it. Will probably boot in X and copy contents to another drive and reformat in HFS+ format, unless someone else has an easier solution.
 

Bart

Registered
I thought I was installing X on the last partition of my multipartition HD, but apparently it was the next-to-last. Now my last partition is invisible, just like with you all. It might be a HFS disk too, so maybe that's the problem instead of it being behind the MacOS X partition. I'll try to run a 3rd party disk repair util on it, maybe that'll help. Does anyone know of it being next-to-last might have anything to do with it?
 

mritchie

Registered
I too had the problem of disapearing HFS

To Get them back I used Norton 5 under 9.0.4 and the drives fixed themselves. One still likes to disappear but it was only a LinuxPPC Boot drive. The drives all still appear in MacOS X so it doesn't worry me as that is all I'll use from now on..Perhaps a little classic but my machine has not been switched off since it was installed. Other than a couple of time to demonstrate the speed of the cold boot.

I'll let you know if it ever falls over and requires a total restart.
 
Top