how do i enable ip forwarding?

djeans

Registered
I have been using natd to share a cable modem with the public beta, but have been having problems since the 10.0 release of X. Can anyone tell me an easy way to enable ip forwarding, and have it enabled at startup?

Thanks

Darron
 

blb

`'
If you look at /etc/hostconfig, there is a line for IP forwarding. Try setting it to -YES- and reboot. Note, I haven't tried this myself...

After the reboot, run (in a terminal):

sysctl net.inet.ip.forwarding

and see if it is set to 1. If not, the hostconfig setting may be ignored, and you'd have to run

sysctl -w net.inet.ip.forwarding=1

to set it.
 
Top