how to setup a Samsung ML-1740 for network printing (lpr)


This little laser is available quite cheaply. I got it going nicely on my LAN, printing from OSX (10.4.1), WinXP, Win98.

There are some hard to find details so I thought I would put the details in the forum for all to access. I had earlier found the info about the Australian Samsung drivers via google hits pointing to the forums here, which was an essential find!

Thanks for the free mac tech support.


Samsung Ml-1740- Network Print From Os X?

On Jul 10, 7:38am Brian wrote:
I just set up a Samsung ML-1740 laser printer on a Belkin 2-port USB print server (model F1UP0301).

I read in the forums here that it printed fine from OS X if you use the drivers available only from Samsung Australia- and it does just fine at this time.

I can print to it across my home LAN from Win98 and XP but I have not figured out a way to do the same from OS X.

The Samsung is not a postscript printer, the Samsung drivers do the rendering on the local host CPU then dump to the printer.

The Belkin USB printserv says it's a lpr printserver.

I think I'm stuck using this as a wired printer from OS X but would love to find a way to print to it from the network from my Macs.

The Samsung ML-1740 is not listed as a supported model from the sourceforge gimp-print pages.

I think I might be able to make it work if I put it on an OS X (10.3) box and shared it on the network from there (for OS X laptop and Windows laptops to use), but I don't wish to leave my B/W OS X CPU on continually. Would this work for sure though? I don't see anyone in the forums posting about this type of setup.

Could I make this work if I got a different printserver? The Belkin one is a little cheesy.

Thanks for help;

Disclaimer: Advice given here is from someone you might consider a friend, co-worker, neighbor or family member. Please consider this when doing things you may feel unsure of. At no time do we endorse breaking your manufacturer’s warranty.
On Jul 10, 7:53am Brian wrote:

Oh I should mention I tried setting up IP printing in the OS X (10.4.1) print/fax utility.

I can set up the IP printing, but when I chose the ML-1740 driver via the "other" printer drivr dialog, instead of staying set to ML-1740 it resets to "generic postscript" which won't work- this isn't a postscript printer.

Print jobs sent to that IP as generic postscript, just vanish- no error, no output.
I would have expected raw postscript output....

On Jul 10, 8:52am gsahli . wrote:
It sounds like you understand the basic problem: Except for Brother, none of the non-postscript printer makers provide a driver that uses CUPS - therefore you get only the protocol they wrote into it - usually USB.

I don't have a Samsung, but I believe your printer uses a print language called samsung-gdi. Here's what I'd do:
Install the Samsung-gdi package:
Install this slightly newer ESP ghostscript:
ADD it as an LPR printer, including entering the Belkin-specific queue name of lp1 for port one or lp2 for port two.
For model choice, use ML-1210 (because someone said that works for several newer models, and 1740 isn't in there yet).

Good luck.

On Jul 10, 2:30pm Brian wrote:

The linux-gdi drivers with the newer ESP drivers work super. I'm printing wirelessly from 10.4.1.

Everything I've tried has printed properly so far.

I'm not sure I would have found those drivers, a lot of googling hadn't turned them up yet.

Plus, I think this means that I don't care if samsung ever updates/make new OS X drivers (apparantly they have said they are holding off, Apple has had too many OS changes recently or something).

Thanks so much!

Will/could this show up on the forums? I don't think this is covered there yet, and it's looking like a great little laser printer for a super price.

Thanks again!

I used the same drivers from Samsung in Australia. I had success with D-Link's DP-301U Ethernet PrintServer. Bonjour found it right off the bat. However the instructions with the driver said to use IP Printing, so that is how I set it all up. I can now print from either Mac platform or any of my three PC platforms.
The installation of the Samsung ML-1740 via USB went very well. However, when I move the printer to a Bluetooth/USB adaptor, the OSX 10.4.6 Bluetooth Printer Setup Utility finds the printer, but failed to configure it, claiming "An appropriate driver for that printer could not be found". It doesn't seem to be finding the USB driver, and I don't know how to point it to the driver's folder.

The Bluetooth Printer Adaptor is an Anycom PM-300, which does work on a Windoze Computer.

Any suggestions?