HP PSC950 MacOS 10.1 problems


HP PSC 950 & MacOS 10.1?

First of all, it wouldn't let me install on a UFS boot disk. Formatted it and installed MacOS X (10.0). Installed the drivers, and everything appeared OK.

Upgraded to 10.1 and the applications I tried seemed to work, but the HP Director couldn't find any of the tool functions.

Did a fresh install of 10.1, selected "format destination", then installed the HP drivers. Install went fine, but nothing works at all.

I see there's a known-issue w/HP Director that rebuilding the desktop (hold down option and command keys when restarting) can fix.

Guess I'll start over with 10.0. Ugh.

Update - installed 10.0, did the "software update", but I'm not sure what it did -- it's the one before it offers 10.0.4. "About" says build 4K78. Everything appears to work fine.

I'm DL'ing the 10.0.4 update now.

I had the same problems with the HP printer. I upgraded to 10.1.1 and Director would hang when I started it. It still isn't right, but I am able to print and scan now without too much trouble. Here's how:

First, make sure you have the latest driver (and be sure to <b>completely</b> uninstall the old driver before installing the new one). It doesn't officially support 10.1.1, but it does work. You have to call them and have them send it to you; it's not available for download because of 3rd party limitations. The version they sent me is 1.0.1. I've emailed them a couple of times, and they assure me that an update will be available soon, and that it may be downloadable.

When you start Director, about half the time the scan, copy, fax, etc. options will be grayed out. If that happens, close Director (you may have to Force Quit), and hit the power switch on the printer. After it shuts down and does the self-test, press the power button again.

This worked for me. It seems to be a problem with the USB.