I book wont boot from cd


Trying to install 10.3 on a ibook ( 1.07g4 256mb, 12"). It just wont boot from cd. Weather i use the install icon in on the disk which prompts to restart or by holding down c. I get the screen with the apple then the apple shifts to the ricght and the system freezes. Tried booting to safe mode, Apple dissapeared and was replaced by blue and pink lines in a square. Could use some help (as if that wasn't obvious)
Thanks in advance
Have you tried swapping out whatever RAM might be in there? If there's only one, then there's not much you can do about it being a RAM problem other than getting new modules.

The only other thing I can think that it might be is that your iBook might need some sort of firmware upgrade. For that, head on over to Apple's website and go to Support-->Downloads. Do a search for "firmware ibook G4" and see what comes up. If there is one, you'll see it in the search hits.
One other thing...

Is this an OFFICIAL Mac OS X installation disc? Did this disc come with the iBook originally (it will say iBook on it if it came with the iBook)?

If neither of these are true, then it must be an illegal copy (which could mean that it wasn't created properly...and that person will "burn in hell" according to Steve J.), or it's a restore CD for another Macintosh system (which means that it won't boot on anything other than the system listed on the disc).
It is a full retail version of 10.3. The only ram is the onboard stuff so i hope thats not it. Also its not just my panther disk it wont boot off my norton disk either ( i know I know found out it sucks after i bought and opened it). MY 14" ibook boots of both so i know its something with this ibook :(
anyother ideas