I can't delete unwanted email

piquant

Registered
It used to be that when I selected a message in my IN box and pressed "delete," the message would end up in TRASH. Now when I press "delete," nothing happens. The message stares back at me without blinking.

Should I choose an alternate route: Mail > Message > Move To > Trash, again nothing happens.

How can I force my machine to delete unwanted email messages? I'm running Mail.app 1.3.11 on OSX 10.3.9.
 

piquant

Registered
#1 Rhapsody:

I've tried that and every other option provided by the menu — I need a more devious solution than the obvious. Thanks for the thought.
 

kisuke3

Registered
Your mail could've corrupted so try to set it up again if its not doing what it should
Quit your mail program
1.back up your mail folder ~/Library/Mail above all else just to make sure
2. move the com.apple.mail.plist to the desktop
3. relaunch mail. All of your mail should be inside since you didn't actually remove/delete anything. You Can try to delete the mail account and reset it up
4. Once set up you can try importing the mail folder to Mail app again so you have all your mails once again with the folders
 

piquant

Registered
kisuke3:

By the sheerest dumb luck, I stumbled into the solution to my problem. I was clicking and pressing up a storm when I went down this road: Mail > Preferences > Accounts > Special Mailboxes where a drop-down menu gave me 4 options. All I had to do is select: Erase Messages when > Quitting Mail.

That was it. For whatever reason, I had previously selected: Never!

Thank you for your effort, I appreciate your thought.
 

mwilky

Registered
Hi, I signed up for this forum specifically to say thanks to Piquant for the "dumb luck" solution to this maddening issue (and to all the others of you who are wrestling with it). I have several mailboxes, but using the Mail>Preferences>Accounts>Mailbox Behaviors route, I was able to reset the Junk mail and Trash parameters for each mailbox. The view of an empty Trash box warmed the cockles of me heart. Thanks again all.
PS. In case it matters, this worked for my gmail accounts and I am running Yosemite (OS X 10.10.1).
 

phillman5

Registered
much later in time here, but had the same problem with Monterey. The message had 0 KB size. Tried all the ways to delete. I went to trash, and emptied it. (menu Mailbox/Erase Deleted Items/ than chose account affected.) Then the message showed 55 KB in size, and I was able to delete it.
 
Top