I Can't Restart Or Log Off From System Software


Hi Everybody! Just sighned up.I hope you can help me.
I can not log off, I can not restatr, the only way I can shut down my I book G4 is by pressing P{ower Button.

Is there any way I could fix it, hellp me please?


yep, I got same here, I read lots threads and it was suggested following, I did them all and still same, I am working on the java update one and hope that will work.

this is my thread hope that help u, well it did help me:)

OSX cannot shutdown restart or swicth user

Hi, folks

I have switched from PC half year ago and my experience with OSX is very good so far.

One day I came back from work and my wife told me our imac G5 is freezing,
I took a look and did a shutdown by holding on the power button.

After that it stucked in a blue screen, and I did a few times hold power button as that is my only choose, it was not helping.

Therefore I decide to do the PC way, take out my OSX disk and did a re-install with keeping my previous user profile.

It login ok after that but I notice two issue is happening

1. I cannot switch user by clicking the username in right top corner, and it turns to the color ball forerver.

sometimes it works if u just login but after a good mac use 30 mins, it will not be able to switch user as above described.

2. I no longer can do restart or shutdown from finder
after I click on it, it just do nothing, no color ball, no CPU high, just nothing

However, I can do shutdown from terminal, and sleep and force to quit is working from finder.

I notice shutdown problem is happending after I did a onyx and onyx is able to shutdown mac after did a scan.

3.while I doing update I see some red process hang and update cannot complete, but I am not sure which patch I am updaing.

I have a feeling this is the root of all this three issues, as I kind of remember I was updating before this all happned.

BTW, I am a very heavy BT user, not usre this helps or not.

Following is what I did so far

re-install OSX with keep user profile(twice)
fsck repair
nvram reset
removed com.apple.finder.plis, com.apple.sidebarlists.plist

Someone suggested to delete the folder 'Quickbackstartup' (part of 'speedtools')in the startupitems folder in the Library folder.
However, I cannot find that file.

I am using Imac G5 1.8 10.3

many thanks for viewing my threads


Mac of the SubGenius! :-)
OK, when you start up the Mac, right after the chime hold down Apple-S. This will put you into Single User Mode (get ready for some UNIX love :D). Once at the prompt, type "/sbin/fsck -yf" and hit return. Let it find what it does and repair. Once it finishes, type it again until you see that it says that the hard drive is OK. Then type reboot. If after the reboot you are able to get in, then once you log in head over to Applications-->Utilities-->Disk Utility and select to repair permissions on your hard drive. After it finishes the first time, run it again to make sure it repaired everything. Reboot.

If the above doesn't help, try this: After the startup chime, hold down Apple-Option-P-R. This will "zap the PRAM." It will reset some settings and will cause the Mac to reboot and you'll hear the chime again. Keep holding down those keys for about 4-5 times after the first startup chime from whence you started holding down the keys. After that, repeat the steps above.

I hope this helps for all of you. If not, then you might have to try something like Disk Warrior or just backup what you can and reinstall the OS. :(


Mac of the SubGenius! :-)
To tonyfeng75:

Shutting down OS X in that manner is a definite no-no. That's probably what is causing all of these problems. I don't think bittorrent is to blame, unless you downloaded one of those rootkits masquerading as an application or music file.

Have you tried creating another user and logging in as that account? Hopefully you won't see any problems with the newly created account, meaning you can just move your files in your home folder over to the new account and delete the old one. Just make sure that you give the new account admin priveleges.

Other than that, you might have to do an archive and install of the OS. :(

Although it's probably not this, make sure that it's not a hardware problem. If it's one of the iMac G5s that were released this summer you might be OK in this respect. However, if it's one of the first generation iMac G5s then you might have a hardware problem which you should have Apple look at. There have been others with similar problems on the first-gen iMac G5 and they've had to send it to Apple for repair.


Thanks for the quick reply guys!!

I agreed that powerdown was not a good move, but I did not have any choice at the time, nothing else was working:)

I did fsck -y but not "/sbin/fsck -yf" like suggested, not sure they are different.
when I did fsck, fan sounds really huge and it only return "system has been modified" in the end, I have ran twice.

I did zap the PRAM once, but nothing really changed.

And New admin user also have the shutdown problem.

I think maybe re-install will be my last choice, but I have no idea how to archieve my system.

Is it possible to archieve system to DVD and my BT will still continues download from where it re-installed?

I dont have disk worrier and other software to repair:) this mac cost me huge already

Thanks again to help to trouble shoot:)


Mac of the SubGenius! :-)
Adding the "f" at the end will force a cleaning of the system. Try it again in Single User Mode and do the command I suggested. If the filesystem is journaled, it will tell you to do this even if you do it without the "f" at the end.


dear nixgeek, I tried to tipe in "/sbin/fsck-yf" but nothing happend, it said that there no such a file, when I tiped in fsck ,it told me that the volume is journaled and I have to use-f option to force check. So do you think if I use force check maybe it could help, And how the hell I tell the system to run -f option.
Thanx in advence


Mac of the SubGenius! :-)
There is supposed to be a space between "fsck" and "-yf". HEnce the error.

It's like this:

/sbin/fsck <hit spacebar> -yf <hit return>


Hi, Following are my latest update for this issue.

I did above suggested fsck about eight times in the single user mode and the command said the HD is repaired each time.

I also did a hard disk repair by booting with my OSX CD and launch Disk Utility.

Firstly I verified the disk and try to repair after it suggested to repair,
I found each time after it finished repairing if I do a verify agian, it always said the disk needed to be repair.

I did this about 5 times and everytime it said this disk need to be repair,
I guess it means my disk is toast.

What you epxerts think, I hope a format can help !**, and I really hope warranty cover hard disk because I dont have the budget to change hard disk.


Be honest, I dont think they gave me the message that tells anything wrong, neither in FSCK or Disk Utility, FSCK told me the system was modified and Disk Utility said the system need to be repair(although I did a few times).