ibook boot issues

ibooker

Registered
Hi all.
I hope someone can help!

I have a much loved ibook G4 14" (late 2004??). It has just died. Well, in so much as it won't boot up. The ibook either gets as far as the apple grey screen and hangs, gets to the login screen and hangs, actually loads up finder etc and hangs or none of the above. Sometimes flashing red, blue green black.

After lots of research online over the past few days I tried the following: I have tried safe mode (not working), starting the command prompt screen (single user and verbose modes), started open firmware, and tried booting from a CD. Nothing works as the boot gets so far then hangs. I have flashed the PRam, resetted the NVRam, and have stopped short of opening up the case to dismantle it!

I just really want to access the hard drive now. I have tried Target disk mode and linked the ibook via firewire to a PowerPC G5, but the G5 doesn't recognise the ibook!? System profiler on the G5 shows the target mode connected and working fine via firewire, just the icon for the ibook/target doesnt mount on the G5 desktop so I cant access it.

Currently the boot freezes within a couple of minutes.

I tried the hardware test CD that came with the ibook years ago, I have also tried booting from an OSX Panther CD. I'm assuming they would be bootable.

I forgot to mention that in linking with the G5 in target mode, a disk that I put in the ibook drive appeared on the G5 desktop as an external drive, therefore I wonder why i cannot see the actual ibook hard drive mounted. The CD drive works as it mounted on the G5.

Does the ibook have an actual PRam battery that can be replaced? Maybe this is an issue?

Am I able to actually remove the hard-drive and access it as an external drive somehow?

Does anyone have any suggestions?
I'll buy you a pint.

Please help!
Thanks!
 

pandoraEudora

Registered

lbj

Registered
Trying pushing firmly on the left wrist area approximately one inch below the keys and one inch left of the trackpad. Keep applying pressure and see how far you get in the boot process. If successful, consider a c-clamp to the area long enough to retrieve your data. I am not making this up--it worked for me. Good luck.
 
Top